Bug 141600 - fails to load piix module
fails to load piix module
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 08:56 EST by raxet
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 02:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description raxet 2004-12-02 08:56:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
install rpm -ivh on all flavors yields the following warning :

Preparing...               
########################################### [100%]
   1:kernel                
########################################### [100%]
WARNING: No module piix found for kernel 2.6.9-1.1009_FC4.root,
continuing anyway

Finally on reboot kernel panic - missing piix module - is never created

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.1006, 1008, 1009 all flavors

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh kernel-2.6.9-1.1006, 1008 or 1009 all flavors
2. error on reboot - kernel panic
3.
    

Actual Results:  upon reboot kernel panic

Expected Results:  boot normally

Additional info:
Comment 1 raxet 2004-12-02 09:01:51 EST
This is actually ata_piix. Just to give a little history here. Every
dev and release FC since 2 on has detected and loaded the module
ata_piix on new install from FC2 t1 - t3 and FC3 t1 - t3 and releases
FC2 and FC3.

No reason for it to be dropped.
Comment 2 Dave Jones 2005-01-14 02:27:27 EST
config-generic:CONFIG_SCSI_ATA_PIIX=m

not a problem in the current kernels at least.

Note You need to log in before you can comment on or make changes to this bug.