Bug 1416065 - Content Hosts - UI is slow during scale
Summary: Content Hosts - UI is slow during scale
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1540632
TreeView+ depends on / blocked
 
Reported: 2017-01-24 14:03 UTC by Pradeep Kumar Surisetty
Modified: 2019-09-26 14:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1540632 (view as bug list)
Environment:
Last Closed: 2018-02-14 14:21:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pradeep Kumar Surisetty 2017-01-24 14:03:15 UTC
Description of problem:

We added 6000 hosts to satellite/capsule. Each capsule has 2 to 2.5k content hosts. Start changing location of few content hosts (500) using hammer.

 hammer --username admin --password changeme host update --name gprfc20.container3.example.com --location-id 5

Open content-hosts UI page takes more than > 38 sec
 

Version-Release number of selected component (if applicable):
satellite: 6.2.6

How reproducible:


Steps to Reproduce:
1. initiate  changing location of 500 content hosts 
2. open content-hosts page (where 6k registered)
3.

Actual results:

UI takes > 38 sec

Expected results:

UI should take lesser time
Additional info:

Comment 8 Brad Buckingham 2018-01-31 14:55:31 UTC
This bugzilla is discussing 2 different performance issues (content hosts and remote execution).  I am going to clone this bugzilla so that the 2 issues may be tracked separately.

Comment 9 Justin Sherrill 2018-02-14 14:16:49 UTC
Tested on 6.3.0.  Registered 6000 hosts. Content host page took between 1 and 4 seconds to render.  Ran:

for i in `seq 100 600`; do hammer host update --id=$i --location-id=3; done

Accessed the content host page a few times.  Took between 1 and 4 seconds still.

Comment 10 Justin Sherrill 2018-02-14 14:21:51 UTC
Closing since i cannot reproduce on 6.3.0.  If you still experience the content hosts slowness, please feel free to reopen with more details.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.