Bug 1416159 - [RFE] report of async tasks failure reason to the user
Summary: [RFE] report of async tasks failure reason to the user
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Fred Rolland
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 17:55 UTC by Kevin Alon Goldblatt
Modified: 2017-11-26 14:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 14:23:57 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
server, vdsm, engine.log (932.21 KB, application/x-gzip)
2017-01-25 08:20 UTC, Kevin Alon Goldblatt
no flags Details

Description Kevin Alon Goldblatt 2017-01-24 17:55:17 UTC
Description of problem:
After previous failure on target trying to cold move the same disk again fails with - Volume already exists


Version-Release number of selected component (if applicable):
vdsm-4.19.2-1.gitd9c3ccb.el7.centos.x86_64
ovirt-engine-4.1.0.3-0.0.master.20170122091652.gitc6fc2c2.el7.centos.noarch


How reproducible:
always

Steps to Reproduce:
1. Create VM with preallocated disks and power VM off
2. There is only an SPM on this system
3. Select to Move the block disks to another domain
4. As soon as the move starts block the connection between the SPM and the Storage Domain - As expected the move fails
5. Restore the connection between the SPM and the storage domain
6. Try moving the same disks again >>>> 1 succeeds while 1 fails with Volume already exists 

Actual results:
Failed to move disk after a previously failed move operation

Expected results:
A cleanup should succeed and the new move should work

Additional info:
From engine log
-----------------------------------------
2017-01-24 18:26:30,388+02 INFO  [org.ovirt.engine.core.bll.ConcurrentChildCommandsExecutionCallback] (DefaultQuartzScheduler3) [7751b23b] Command 'MoveOrCopyDisk' (id: '3af78a72-0970-4e33
-8430-df378e388905') waiting on child command id: '9bcff944-c781-4b11-bc6e-40d85b1e21b0' type:'MoveImageGroup' to complete
2017-01-24 18:26:31,204+02 INFO  [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (DefaultQuartzScheduler6) [15090fc0] Polling and updating Async Tasks: 2 tasks, 2 tasks to poll now
2017-01-24 18:26:31,227+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler6) [15090fc0] EVENT_ID: VDS_BROKER_COMMAND_FAILURE(10,802), C
orrelation ID: null, Call Stack: null, Custom Event ID: -1, Message: VDSM purple-vds1.qa.lab.tlv.redhat.com command HSMGetAllTasksStatusesVDS failed: Volume already exists
2017-01-24 18:26:31,228+02 INFO  [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler6) [15090fc0] SPMAsyncTask::PollTask: Polling task '9a2a2eaa-ca3c-47d2-95b8-b070f4626
022' (Parent Command 'CreateVolumeContainer', Parameters Type 'org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters') returned status 'finished', result 'cleanSuccess'.
2017-01-24 18:26:31,234+02 ERROR [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler6) [15090fc0] BaseAsyncTask::logEndTaskFailure: Task '9a2a2eaa-ca3c-47d2-95b8-b070f46
26022' (Parent Command 'CreateVolumeContainer', Parameters Type 'org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters') ended with failure:
-- Result: 'cleanSuccess'
-- Message: 'VDSGenericException: VDSErrorException: Failed in vdscommand to HSMGetAllTasksStatusesVDS, error = Volume already exists',
-- Exception: 'VDSGenericException: VDSErrorException: Failed in vdscommand to HSMGetAllTasksStatusesVDS, error = Volume already exists'
2017-01-24 18:26:31,236+02 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (DefaultQuartzScheduler6) [15090fc0] CommandAsyncTask::endActionIfNecessary: All tasks of command '7d34a
7bb-2e73-4527-a773-572acadfa577' has ended -> executing 'endAction'
2017-01-24 18:26:31,236+02 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (DefaultQuartzScheduler6) [15090fc0] CommandAsyncTask::endAction: Ending action for '1' tasks (command I
D: '7d34a7bb-2e73-4527-a773-572acadfa577'): calling endAction '.

Comment 1 Kevin Alon Goldblatt 2017-01-25 08:20:24 UTC
Created attachment 1244189 [details]
server, vdsm, engine.log

Adding logs

Comment 2 Liron Aravot 2017-01-25 17:24:59 UTC
As the destination images aren't cleared on that scenario with proper audit log the new move operation fails - that's the issue described in BZ 1416113.
What we may improve as part of this BZ is to report the reason for operation failure to the user so he won't have to look for it in the logs.

Tal - Do we want to have that? if yes, for what version?

Thanks,
Liron

Comment 3 Yaniv Lavi 2017-06-13 09:22:36 UTC
Please reply to comment #2

Comment 4 Yaniv Lavi 2017-11-26 14:23:57 UTC
For now, we fixed the audit log to display error.
Since this is not a major case, closing and CEE can reopen a similar issue if they need this for debugging.


Note You need to log in before you can comment on or make changes to this bug.