Bug 1416169 - Bad documentation link in RHCS 2.0 release notes
Summary: Bad documentation link in RHCS 2.0 release notes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 1.3.4
Assignee: Bara Ancincova
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 18:25 UTC by Kyle Bader
Modified: 2017-02-20 14:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-20 14:56:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kyle Bader 2017-01-24 18:25:30 UTC
Description of problem:

Release notes for RHCS 2.0 contain a incorrect link for swift object expiration.

How reproducible:

Open the document located at this url

https://access.redhat.com/webassets/avalon/d/Red_Hat_Ceph_Storage-2.0-Release_Notes-en-US/Red_Hat_Ceph_Storage-2.0-Release_Notes-en-US.pdf

Steps to Reproduce:

1. Search for "Swift Object Expiration", or browse to page 9.
2. Examine outside documentation that is linked to

Actual results:

 The links that are supposed to provide details on how to configure buckets for object expiration point to the section in the RHEL OSP 8.0 configuration reference that details how to configure Swift (the system) for object expiration.

Expected results:

Client side API documentation on how a tenant can configure bucket object expiration policies. For example, the first three paragraphs of this page:

http://docs.openstack.org/developer/swift/overview_expiring_objects.html

Comment 4 Kyle Bader 2017-02-01 18:36:48 UTC
The current release notes link here:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/single/configuration-reference/chapter-10-object-storage#object-expirer-configuration

Which describes how to configure Swift, the server side, for object expiration. This isn't applicable at all when Ceph is providing the Swift API through the RGW. We need to show tenants / clients how to use enable bucket versioning on one of their buckets. The new link I provided probably isn't the best, because it describes using the X-Delete-At or X-Delete-After headers in bucket PUT operations, but also describes how to do the Swift server side configuration. We only want the former, not the later.

This is probably a more apt description of what it should look like:

https://community.runabove.com/kb/en/object-storage/how-to-schedule-deletion-of-objects.html


Note You need to log in before you can comment on or make changes to this bug.