Bug 1416185 - Rendering overlap between env. variables and docker labels boxes for Container Image summary screen
Summary: Rendering overlap between env. variables and docker labels boxes for Containe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: GA
: 5.8.0
Assignee: zakiva
QA Contact: Einat Pacifici
URL:
Whiteboard: container:ui
: 1416463 (view as bug list)
Depends On:
Blocks: 1428511
TreeView+ depends on / blocked
 
Reported: 2017-01-24 19:14 UTC by Jerome Marc
Modified: 2018-04-17 11:31 UTC (History)
12 users (show)

Fixed In Version: 5.8.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1428511 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:56:27 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:
epacific: automate_bug+


Attachments (Terms of Use)
Screenshot showing overlap in container image summary view (131.53 KB, image/png)
2017-01-24 19:15 UTC, Jerome Marc
no flags Details
Screenshot showing overlap in container image summary view in CFME 5.7.1.3 (164.51 KB, image/png)
2017-03-09 07:15 UTC, Jerome Marc
no flags Details

Description Jerome Marc 2017-01-24 19:14:37 UTC
Description of problem:
See screenshot attached. Boxes for 'Environment Variables' and 'Docker Labels' are overlapping in the Container Image summary screen after performing SmartState Analysis. This is probably caused by the PATH field not being trimmed correctly. 

Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f 

How reproducible:
Always

Steps to Reproduce:
1. Navigate to a Container Image summary view (after being scanned)
2. Resize your browser window if required to get this overlap.

Actual results:
'Environment Variables' and 'Docker Labels' are overlapping

Expected results:
'Environment Variables' and 'Docker Labels' should not overlap

Additional info:

Comment 2 Jerome Marc 2017-01-24 19:15:56 UTC
Created attachment 1244037 [details]
Screenshot showing overlap in container image summary view

Comment 3 Federico Simoncelli 2017-01-24 22:02:00 UTC
Harpreet IIUC this is something that would happen on other screens as well when the view is reduced.

Or is this related to our wrong use of the tables?

Comment 5 Harpreet Kataria 2017-01-25 15:39:57 UTC
*** Bug 1416463 has been marked as a duplicate of this bug. ***

Comment 12 Federico Simoncelli 2017-03-07 22:44:31 UTC
The PR that really fixed this issue moving the "Environment Variables" table on the right side of the screen (preventing the overlapping but generating an overflow) is:

https://github.com/ManageIQ/manageiq-ui-classic/pull/274

Comment 13 Jerome Marc 2017-03-09 07:15:14 UTC
Created attachment 1261450 [details]
Screenshot showing overlap in container image summary view in CFME 5.7.1.3

This issue still occurs in CFME 5.7.1.3 (see attached screenshot).

Comment 16 Einat Pacifici 2017-04-20 09:00:10 UTC
Verified. The Environment Variable Table is now on the right side of the screen. Below it is the Docker Labels table. Hence, no overlap is seen.


Note You need to log in before you can comment on or make changes to this bug.