Bug 141629 - Up2date fails on "Downloading headers to solve dependencies"
Up2date fails on "Downloading headers to solve dependencies"
Status: CLOSED DUPLICATE of bug 140348
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 11:34 EST by Joshua Wilson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 12:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wilson 2004-12-02 11:34:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
[root@setup ~]# up2date -u

Fetching Obsoletes list for channel: rhel-i386-ws-4-beta...

Name                                    Version        Rel
----------------------------------------------------------
chkconfig                               1.3.11.2       1                 i386
curl                                    7.12.1         3                 i386
curl-devel                              7.12.1         3                 i386
httpd                                   2.0.52         7.ent             i386
httpd-suexec                            2.0.52         7.ent             i386
mod_ssl                                 2.0.52         7.ent             i386
ntsysv                                  1.3.11.2       1                 i386


Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 74, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 159, in __dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 553, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 520, in process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 307, in __dependencies
    msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 93, in solveDep
    msgCallback = msgCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line 44, in solveDep
    msgCallback = self.msgCallback)
TypeError: getSolutions() got an unexpected keyword argument 'progressCallback'

I can not update any of these packages, because I get the above error and then up2date stops.

Version-Release number of selected component (if applicable):
up2date-4.3.53-1.i386.

How reproducible:
Always

Steps to Reproduce:
1. Installed Beta1
2.  run up2date -u
3. I get the error
  

Actual Results:  the up2date will not update the following packages

chkconfig                               1.3.11.2       1                 i386
curl                                    7.12.1         3                 i386
curl-devel                              7.12.1         3                 i386
httpd                                   2.0.52         7.ent             i386
httpd-suexec                            2.0.52         7.ent             i386
mod_ssl                                 2.0.52         7.ent             i386
ntsysv                                  1.3.11.2       1                 i386

Expected Results:  update the packages

Additional info:

I had about 50 updates to apply. I could update them 1 by 1 as long as none of the packages listed in the actual results were not selected.
Comment 1 Joshua Wilson 2004-12-02 12:38:51 EST
It is mostly that I can not update these particular packages. If you do this
through gnome then up2date just hangs and won't download the header information.
Comment 2 Joshua Wilson 2004-12-02 12:41:02 EST

*** This bug has been marked as a duplicate of 140348 ***

Note You need to log in before you can comment on or make changes to this bug.