Bug 1416309 - unexpected TAB order in the add provider (of external networks) window
Summary: unexpected TAB order in the add provider (of external networks) window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.1.0.2
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Marcin Mirecki
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 08:54 UTC by Mor
Modified: 2017-12-20 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:45:32 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 71149 master ABANDONED webadmin: unexpected TAB order in the external network provider panel 2017-01-30 11:56:40 UTC
oVirt gerrit 71374 ovirt-engine-4.1 ABANDONED webadmin: initialize TabIndexes with 1 by default 2017-01-30 15:02:32 UTC

Description Mor 2017-01-25 08:54:51 UTC
Description of problem:
Pressing the TAB key in the add provider (of external providers) window, moves the cursor to the incorrect text-box.

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.0.2-0.2.el7

How reproducible:
100%

Steps to Reproduce:
1. Click "External providers"-->Add button.
2. The cursor should be located at the first textbox - Name.
3. Press tab.

Actual results:
Cursor doesn't appear in window.

Expected results:
Should be on "Description"

Additional info:

Comment 1 Marcin Mirecki 2017-01-30 15:03:53 UTC
The bug is already solved by patch: https://gerrit.ovirt.org/#/c/71199/

Comment 2 Marcin Mirecki 2017-05-29 10:02:07 UTC
The order is now correct, but the cursor does appear.
Moving back to assigned.

Comment 3 Mor 2017-06-01 08:29:07 UTC
I had a discussion with Marcin about the cursor losing focus issue, it appears that this issue is a generic UI problem. I will try to contact the UI team and ask them if we can add a generic UI bug.

Comment 4 Mor 2017-06-01 08:38:44 UTC
TAB order functionality is verified on version:
4.2.0-0.0.master.20170528182656.git8a070ae.el7.centos

Comment 5 Sandro Bonazzola 2017-12-20 10:45:32 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.