Bug 1416324 - Enhancing bind/bind-chroot module to backup all configs in /var/named/chroot/var/named/ and /var/named
Summary: Enhancing bind/bind-chroot module to backup all configs in /var/named/chroot/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-el6toel7
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Mazanek
QA Contact: Petr Sklenar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 09:47 UTC by Jakub Mazanek
Modified: 2017-08-02 00:09 UTC (History)
4 users (show)

Fixed In Version: preupgrade-assistant-el6toel7-0.6.69-1.el6
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-02 00:09:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2400 0 normal SHIPPED_LIVE preupgrade-assistant-el6toel7 bug fix and enhancement update 2017-08-01 22:04:03 UTC

Description Jakub Mazanek 2017-01-25 09:47:45 UTC
Description of problem:
Previously , module backed up only part of the files. This was adjusted based on the review from package owner.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Alois Mahdal 2017-06-22 19:27:46 UTC
Thanks for nice explanation.

Comment 9 Petr Sklenar 2017-07-10 12:55:52 UTC
there is issues with rights:
1, 

Jul 10 08:31:00 localhost.localdomain named[1753]: open: /etc/named.conf: permission denied
Jul 10 08:31:00 localhost.localdomain named[1753]: loading configuration: permission denied
Jul 10 08:31:00 localhost.localdomain named[1753]: exiting (due to fatal error)

2, with /etc/rndc.key

this could be enough:
chgrp named /var/named/chroot/etc/named.conf
chgrp named /var/named/chroot/etc/rndc.key

Comment 14 errata-xmlrpc 2017-08-02 00:09:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2400


Note You need to log in before you can comment on or make changes to this bug.