Bug 141635 - S3 Savage IX forces display to 640x480, even when configured for 1600x1200
S3 Savage IX forces display to 640x480, even when configured for 1600x1200
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 11:54 EST by Jay Fenlason
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 23:11:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (13 bytes, text/plain)
2004-12-03 12:41 EST, Jay Fenlason
no flags Details
Xorg.0.log (31.78 KB, text/plain)
2004-12-03 12:52 EST, Jay Fenlason
no flags Details
Second try at xorg.conf (2.81 KB, text/plain)
2004-12-03 12:54 EST, Jay Fenlason
no flags Details

  None (edit)
Description Jay Fenlason 2004-12-02 11:54:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
I put a S3 Savage IX PCI card in my I810 chipset based FC3 machine
while awaiting a working xorg for i810.  I ran system-config-display
and set the screen resolution to 1600x1200.  When I started X, it came
up in 640x480, and won't do any other resolution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run system-config-display
2.Select a resolution other than 640x480
3.run "xinit"
    

Actual Results:  Very large 80x24 xterm window, big pixels, xdpyinfo
says "640x480", etc.

Expected Results:  Small xterm window, small pixels, etc.

Additional info:

I can bring the machine into the westford office on a few minutes notice.
Comment 1 Mike A. Harris 2004-12-02 14:04:35 EST
Attach X server log and config file from failed setup.
Comment 2 Jay Fenlason 2004-12-03 12:41:31 EST
Created attachment 107848 [details]
xorg.conf file
Comment 3 Jay Fenlason 2004-12-03 12:52:41 EST
Created attachment 107852 [details]
Xorg.0.log
Comment 4 Jay Fenlason 2004-12-03 12:54:27 EST
Created attachment 107854 [details]
Second try at xorg.conf

web browsers on RHEL3 and bugzilla don't get along well.
Comment 5 Mike A. Harris 2004-12-07 04:15:43 EST
(II) SAVAGE(0): Not using default mode "1600x1200" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "800x600" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "1600x1200" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "800x600" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "1600x1200" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "800x600" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "1600x1200" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "800x600" (exceeds panel
dimensions)
(II) SAVAGE(0): Not using default mode "1600x1200" (bad mode
clock/interlace/doublescan)
(II) SAVAGE(0): Not using default mode "800x600" (exceeds panel
dimensions)
Comment 6 Mike A. Harris 2004-12-07 04:19:25 EST
Looks like the driver thinks your panel is smaller than it is.
That could be a driver bug, or it could be something else, hard
to say.

I strongly recommend reporting this bug to X.org at the upstream
bug tracker at http://bugs.freedesktop.org and pasting the URL here,
as this bug probably will require direct physical hardware access
to fix, and would thus benefit from the driver maintainer's eyes,
along with Egbert Eich et al.  I don't know if we have physical
access to this hardware in the Westford office or not, but I don't
have any Savage hardware here I'm afraid.  ;o/

Paste the upstream bug report URL here once you've filed it, and
we can track it there also.

Thanks in advance.
Comment 7 Jay Fenlason 2004-12-07 11:17:44 EST
It's not attached to a panel at all.  It's attached to a ViewSonic 
vaccuum tube (PT815) that can certainly do 1600x1200, so I'd say 
that's probably where the bug is. 
 
I have two of these cards.  One is in 
fenlason-desk.boston.redhat.com (for no good reason--can easily be 
moved) and one is in my fc3 machine (can easily be brought in to the 
office).  Want me to mail you one? 
 
Upstream bug entered: #2028 
Comment 8 Mike A. Harris 2005-01-31 23:11:57 EST
Tracking upstream bug:

https://bugs.freedesktop.org/show_bug.cgi?id=2028

Setting status to "UPSTREAM"

Note You need to log in before you can comment on or make changes to this bug.