Bug 1416354 - Failure of migration of VM's disk that is based on a template, that is not present in target, is not clear.
Summary: Failure of migration of VM's disk that is based on a template, that is not pr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.0.7
: ---
Assignee: Tal Nisan
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On: 1379153
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 10:47 UTC by Tal Nisan
Modified: 2017-03-16 15:32 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1379153
Environment:
Last Closed: 2017-03-16 15:32:56 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC
oVirt gerrit 69080 0 None None None 2017-01-25 10:47:29 UTC
oVirt gerrit 69096 0 None None None 2017-01-25 10:47:29 UTC
oVirt gerrit 69097 0 None None None 2017-01-25 10:47:29 UTC

Description Tal Nisan 2017-01-25 10:47:29 UTC
+++ This bug was initially created as a clone of Bug #1379153 +++

Description of problem:
Failure of migration of VM's disk that is based on a template, that is not present in target, is not clear. The error message should guide the use to copy the template disks first to the target storage.

Version-Release number of selected component (if applicable):
4.0

How reproducible:
Always

Steps to Reproduce:
1. Try to LSM VM's disk that is based on a template to target without a copy of the template.

Actual results:
Error is not clear as to why this fails.

Expected results:
Clear error that says user should copy the template's disk to the target storage.

Additional info:

--- Additional comment from Tal Nisan on 2016-11-29 11:50:06 IST ---



--- Additional comment from Tal Nisan on 2016-12-21 17:50:13 IST ---

There's no elegant way to fit the detailed info in the messages area yet when hovering on each target storage domain the detailed info is displayed so instead I changed the message to let the user know that detailed info can be seen when hovering over that box

--- Additional comment from Tal Nisan on 2016-12-21 17:51 IST ---



--- Additional comment from Tal Nisan on 2016-12-21 17:51 IST ---



--- Additional comment from Tal Nisan on 2016-12-25 12:48:34 IST ---



--- Additional comment from Sandro Bonazzola on 2017-01-25 09:56:37 IST ---

4.0.6 has been the last oVirt 4.0 release, please re-target this bug.

Comment 1 Raz Tamir 2017-01-26 14:50:06 UTC
Tal,
There is still issue here.
When you have env with 3 storage domains and SD1 and SD2 has the template disk and you have a VM thinly copied on SD1 and you want to move the disk to SD3 which don't have a copy of the template's disk, you will not have the option to select it from the drop down list and the reason for that is still missing

Comment 2 Tal Nisan 2017-01-31 09:47:55 UTC
Raz, the bug strictly refers to explaining a disabled and empty storage domain select box, if you think we should also notify about an available selection that does not contain a few storage domains that's another thing, you can open a separate bug for it and I'll add a notice probably at the bottom of the panel that lets the user know that not all the domains are available for that reason

Comment 3 Raz Tamir 2017-01-31 11:45:36 UTC
Verified over ovirt-engine-4.1.0.2-0.2.el7 and open a bug following comments #1,2
https://bugzilla.redhat.com/show_bug.cgi?id=1417901

Comment 4 Raz Tamir 2017-01-31 11:54:50 UTC
Update:
Verified over ovirt-engine-4.0.7-0.1.el7ev

Comment 6 errata-xmlrpc 2017-03-16 15:32:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0542.html


Note You need to log in before you can comment on or make changes to this bug.