Bug 1416378 - samba rpm deps - with yum downgrade = kind of a mayhem
Summary: samba rpm deps - with yum downgrade = kind of a mayhem
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 11:39 UTC by lejeczek
Modified: 2017-04-05 09:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-05 09:06:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
yum downgrade samba (237.19 KB, text/plain)
2017-01-25 14:00 UTC, lejeczek
no flags Details

Description lejeczek 2017-01-25 11:39:25 UTC
Description of problem:

do you see this:

~]$ yum downgrade samba
Resolving Dependencies
--> Running transaction check
---> Package samba.x86_64 0:4.4.4-9.el7 will be a downgrade
--> Processing Dependency: samba-libs = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-common-tools = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-common-libs = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-client-libs = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: libwbclient = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
---> Package samba.x86_64 0:4.4.4-12.el7_3 will be erased
--> Running transaction check
---> Package libwbclient.i686 0:4.4.4-9.el7 will be installed
---> Package samba.x86_64 0:4.4.4-9.el7 will be a downgrade
--> Processing Dependency: samba-common-tools = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-common-libs = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
--> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-4.4.4-9.el7.x86_64
---> Package samba.x86_64 0:4.4.4-12.el7_3 will be erased
---> Package samba-client-libs.i686 0:4.4.4-9.el7 will be installed
--> Processing Dependency: samba-common = 4.4.4-9.el7 for package: samba-client-libs-4.4.4-9.el7.i686
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.9) for package: samba-client-libs-4.4.4

..and process fails.
chained are i686 arch?(libwbclient?) and such a looong list of deps.
Samba downgrade used to work I remember. And it saved a day or two in the past after an upgrade of buggy samba version.

Version-Release number of selected component (if applicable):

4.4.4-9.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Andreas Schneider 2017-01-25 13:44:23 UTC
Could you please use

yum -v downgrade samba

and paste the full output here?

Thanks!

Comment 3 lejeczek 2017-01-25 14:00:22 UTC
Created attachment 1244268 [details]
yum downgrade samba

Comment 4 lejeczek 2017-01-26 11:36:30 UTC
there is more, so it might be a lot further down the chain and more serious(or trivial), here:

]$ yum downgrade bind
Resolving Dependencies
--> Running transaction check
---> Package bind.x86_64 32:9.9.4-38.el7_3 will be a downgrade
--> Processing Dependency: bind-libs = 32:9.9.4-38.el7_3 for package: 32:bind-9.9.4-38.el7_3.x86_64
---> Package bind.x86_64 32:9.9.4-38.el7_3.1 will be erased
--> Running transaction check
---> Package bind.x86_64 32:9.9.4-38.el7_3.1 will be erased
---> Package bind-libs.i686 32:9.9.4-38.el7_3 will be installed
--> Processing Dependency: bind-license = 32:9.9.4-38.el7_3 for package: 32:bind-libs-9.9.4-38.el7_3.i686
--> Processing Dependency: libz.so.1 for package: 32:bind-libs-9.9.4-38.el7_3.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: 32:bind-libs-9.9.4-38.el7_3.i686

I'm not sure where this bug report should go?
thanks

Comment 5 lejeczek 2017-01-26 11:46:55 UTC
ok, because system I run off is Centos, mailing list signals this might the cause, the problem.
If yes, that would be a big! bummer.

Comment 6 Andreas Schneider 2017-01-26 15:43:32 UTC
I see centos and rhel7 packages. Yum also reports issues with your rpmdb. It looks like yum chooses i686 packages for some reason maybe because your package cache is crippled you should fix rpmdb and the metadata cache. If you're running centos and have a mix of packages, I do not see how this can be our fault.

Comment 7 lejeczek 2017-01-26 16:57:24 UTC
But I don't, not a single rpm is 686, and only Centos' repos

repo id                             repo name                             status
base/7/x86_64                       CentOS-7 - Base                       9,363
extras/7/x86_64                     CentOS-7 - Extras                       242
updates/7/x86_64                    CentOS-7 - Updates                      786
repolist: 10,391

there is nothing wrong with rpmdb, problem is IPA - https://bugzilla.redhat.com/show_bug.cgi?id=1370134

Comment 8 Andreas Schneider 2017-04-05 09:06:08 UTC
So, assuming this is fixed with bug #1370134.


Note You need to log in before you can comment on or make changes to this bug.