Bug 1416582 - Make use of docker-storage-setup to setup storage
Summary: Make use of docker-storage-setup to setup storage
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Steve Kuznetsov
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 22:28 UTC by Vivek Goyal
Modified: 2017-07-24 14:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-06-02 13:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vivek Goyal 2017-01-25 22:28:01 UTC
Description of problem:

John Honce just gave me access to one of nodes in openshift cluster and I see
following in /etc/sysconfig/docker-storage.

DOCKER_STORAGE_OPTIONS='  -s devicemapper --storage-opt dm.datadev=/dev/docker-vg/docker-data --storage-opt dm.metadatadev=/dev/docker-vg/docker-metadata --storage-opt dm.use_deferred_removal=true'

This is not how docker-storage-setup generates it. This is old mode and we don't support it for docker storage. Users should not edit /etc/sysconfig/docker-storage-setup and put right options there and dss will setup storage and generate appropriate /etc/sysoconfig/docker-storage.

I am trying to figure out who generates this file and how to move them to
making use of docker-storage-setup.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Scott Dodson 2017-01-25 22:31:16 UTC
Jhon,

How was the host installed?

Comment 2 Vivek Goyal 2017-01-25 22:32:25 UTC
One should be able to just drop following in /etc/sysconfig/docker-storage-setup to setup devicemapper for docker.

DEVS="/dev/xvdb"
VG=docker-vg

Or if you want to setup volume group yourself then setup volume group and specify

VG=docker-vg

And docker-storage-setup will carve out a lvm thin pool volume which will be used by docker.

Comment 3 Scott Dodson 2017-01-25 22:37:58 UTC
So the installer doesn't make use of docker-storage-setup directly because by the time we get to a host it's not likely that we have free storage available. Instead in our documentation we outline the requirement for storage configuration and advise people to run docker-storage-setup. 

See https://docs.openshift.com/container-platform/3.4/install_config/install/host_preparation.html#configuring-docker-storage

Comment 6 Steve Kuznetsov 2017-01-26 18:34:42 UTC
Scott,

Are the playbooks for configuring Docker available to be consumed outside of the full install? I can reconfigure the devenv setup to use them.

Steve

Comment 7 Scott Dodson 2017-01-26 18:40:59 UTC
We have no supported playbooks, I believe there are some playbooks in openshift-ansible that configure docker-storage-setup, but I haven't looked at them. Basically do your best to follow the docs I referenced in comment 3.

Comment 9 Scott Dodson 2017-06-02 13:46:56 UTC
This was a problem in internal tooling so closing notabug.


Note You need to log in before you can comment on or make changes to this bug.