Bug 1416840 - Database scheme update failure upgrading from 2.5 to 2.6
Summary: Database scheme update failure upgrading from 2.5 to 2.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 2.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 15:05 UTC by Andy Speagle
Modified: 2019-07-04 13:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 13:04:04 UTC


Attachments (Terms of Use)

Description Andy Speagle 2017-01-26 15:05:49 UTC
Description of problem:

While trying to upgrade from 2.5 to 2.6, I ran into a schema upgrade failure that caused me to revert to my database backup.  

Version-Release number of selected component (if applicable):

2.6

How reproducible:


Steps to Reproduce:
1.  /usr/bin/spacewalk-schema-upgrade
2. 
3.

Actual results:
delete from rhnChannelArch where label = 'channel-i386-sun-solaris'
*
ERROR at line 1:
ORA-02292: integrity constraint (SPACEWALK.RHN_CHANNEL_CAID_FK) violated - child record found


Expected results:
Successful upgrade.

Additional info:

Comment 1 Andy Speagle 2017-02-08 18:54:41 UTC
Hi Team,

I see that this is assigned... is anyone looking at this?  I have used this Spacewalk instance for about 6 years now... upgrading all the way up from early 1.x ... so, I suspect I have something REALLY old in my database that just wasn't cleaned up from previous upgrades.

This problem is preventing me from really using my Spacewalk instance.

Comment 2 Jan Dobes 2017-02-09 10:45:02 UTC
Hello,

I was looking at this problem and there is broken upgrade script. I will try to prepare updated package.

Comment 3 Jan Dobes 2017-02-09 12:36:27 UTC
Could you try to download and install one of following new spacewalk-schema builds which should have fixed this? Install this package before running spacewalk-schema-upgrade.

RHEL6: http://koji.spacewalkproject.org/koji/buildinfo?buildID=45366
RHEL7: http://koji.spacewalkproject.org/koji/buildinfo?buildID=45367
FC23: http://koji.spacewalkproject.org/koji/buildinfo?buildID=45368

Comment 4 Andy Speagle 2017-02-09 16:31:00 UTC
Yup, that fixed it for me.  Nicely done!

Comment 5 Michael Mráka 2019-07-04 13:04:04 UTC
According to comment #4 the issue has been fixed; closing.
If you disagree feel free reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.