Bug 1416888 - [RFE] Ability to set 'mirror on sync' globally
Summary: [RFE] Ability to set 'mirror on sync' globally
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1371276 1584859 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 17:13 UTC by Rich Jerrido
Modified: 2019-08-12 14:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:11:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Jerrido 2017-01-26 17:13:01 UTC
Description of problem:

As a user, I'd like the ability to set the 'mirror on sync' property globally in a Satellite 6 instance. 

As Satellite 6.2 includes the ability to export increment content (via ISS), being able to disable mirror on sync allows the user to not have to keep older exports of content around. They could

- incrementally Export from source satellite
- disable mirror on sync on the destination (which today has to be done per-repo)
- copy & sync only the incremental content.

Currently today if a user wishes to disable 'mirror on sync', it needs to be done on a per-repo level. 

This RFE requests the ability to set a default mirror_on_sync_policy, similar to that for download_policy, which allows the user to set a default for newly created repos.

Comment 2 Bryan Kearney 2018-01-11 18:38:22 UTC
*** Bug 1371276 has been marked as a duplicate of this bug. ***

Comment 3 Paul Dudley 2018-05-31 21:15:36 UTC
*** Bug 1584859 has been marked as a duplicate of this bug. ***

Comment 4 Bryan Kearney 2018-09-04 18:59:31 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 5 Bryan Kearney 2018-09-04 19:11:30 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.