Bug 141689 - boost upstream bug (atleast i guess)
boost upstream bug (atleast i guess)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 18:01 EST by rudolf kastl
Modified: 2013-08-09 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.33.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 10:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rudolf kastl 2004-12-02 18:01:25 EST
Description of problem:

there seems to be an internal problem with boost:


g++ -Wall -ansi -O3 -finline-functions -Wno-inline -fPIC -DNDEBUG
-DBOOST_PYTHON_DYNAMIC_LIB -I/usr/include/python2.3
-I/usr/local/lib/include -Iinclude -c -o osgDB/ReadFile.os
osgDB/ReadFile.cpp
In file included from
/usr/include/boost/python/return_internal_reference.hpp:12,
                  from osgDB/ReadFile.cpp:12:
/usr/include/boost/python/with_custodian_and_ward.hpp: In static
member function `static PyObject*
boost::python::detail::get_prev<N>::execute(const ArgumentPackage&,
PyObject*)':
/usr/include/boost/python/with_custodian_and_ward.hpp:25: error: `get'
is not a member of `boost::python::detail'
/usr/include/boost/python/with_custodian_and_ward.hpp: In static
member function `static bool
boost::python::with_custodian_and_ward<custodian, ward,
BasePolicy_>::precall(const ArgumentPackage&)':
/usr/include/boost/python/with_custodian_and_ward.hpp:52: error:
`arity' is not a member of `boost::python::detail'
/usr/include/boost/python/with_custodian_and_ward.hpp: In static
member function `static PyObject*
boost::python::with_custodian_and_ward_postcall<custodian, ward,
BasePolicy_>::postcall(const ArgumentPackage&, PyObject*)':
/usr/include/boost/python/with_custodian_and_ward.hpp:86: error:
`arity' is not a member of `boost::python::detail'
scons: *** [osgDB/ReadFile.os] Error 1
scons: building terminated because of errors.

Version-Release number of selected component (if applicable):


How reproducible:

grab pyosg from sf.net and install the dependencys from
http://newrpms.sunsite.dk -> fc3

build pyosg and watch above output

Actual results:
doesent build

Expected results:
should build with unborked boost

Additional info:
cant give any more info at this time
Comment 1 Benjamin Kosnik 2005-03-25 18:33:47 EST
I think this is a problem with pyosg. Can you report the issue there?

I cannot find the package you'd mentioned: the links are now dead.

best,
benjamin
Comment 2 Benjamin Kosnik 2005-09-06 15:18:19 EDT
This is probably fixed in the boost-1.33.0 rpms.

-benjamin
Comment 3 John Thacker 2006-05-05 10:24:39 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.