Bug 1416949 - Revert back EPEL to previous rsnapshot version (1.3.x)
Summary: Revert back EPEL to previous rsnapshot version (1.3.x)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rsnapshot
Version: epel7
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Steven Roberts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 22:09 UTC by g.danti
Modified: 2017-01-27 09:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 09:33:56 UTC
Type: Bug


Attachments (Terms of Use)

Description g.danti 2017-01-26 22:09:28 UTC
Description of problem:
Lately, EPEL switched from rsnapshot 1.3.x to the newer 1.4.x
While being actively maintained and providing some new features, v1.4.x has some serious problems which made the previous version the better one, until these issues are solved.

Two issues are of major concern:
#166, logs are not shown how they should, https://github.com/rsnapshot/rsnapshot/issues/166

#167, warnings are not printed to stderr nor on log files (until very high verbosity is selected), https://github.com/rsnapshot/rsnapshot/issues/167


Version-Release number of selected component (if applicable):
1.4.x

How reproducible:
See the above links to gihub issues

Steps to Reproduce:
1. as above

Actual results:
1. for issue #166, even selecting loglevel 5 no rsync logs are shown in the log file
2. for issue #167, no warnings are shown on stderr or logfile (when loglevel < 5) when rsync report a non-fatal error/exit code (eg: 24)

Expected results:
1. loglevel 3+ should write rsync logs in the log file, as it happens in the previous version
2. according to documentation (and to previous rsnapshot version), warnings should be printed on stderr

Comment 1 James Hogarth 2017-01-27 09:33:56 UTC
The older version will not be built as it is no longer maintained.

Comment 2 g.danti 2017-01-27 09:53:38 UTC
Hi, while I understand that 1.3.x is an old version, the newer 1.4.x has serious flaws that make it unsuitable for production work.

I strongly suggest to revert to 1.3.x and, when #166 and #167 will be solved, to upgrade to 1.4.x

Regards.


Note You need to log in before you can comment on or make changes to this bug.