Bug 1417023 - Minor typos in 'Installing middleware management with cloudforms" [NEEDINFO]
Summary: Minor typos in 'Installing middleware management with cloudforms"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Middleware Manager
Classification: JBoss
Component: Documentation
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: DR2
: ---
Assignee: jstickle
QA Contact: Prachi
URL:
Whiteboard:
: 1410210 1417022 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 02:05 UTC by mario.mendoza
Modified: 2017-02-23 21:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 21:17:05 UTC
mario.mendoza: needinfo? (mmahoney)


Attachments (Terms of Use)

Description mario.mendoza 2017-01-27 02:05:12 UTC
Document URL: https://access.redhat.com/documentation/en/red-hat-middleware-management/7.0.techpreview/single/installing-red-hat-middleware-management-with-cloudforms/

------------------------
Section Number and Name: 

1.3.2. Installing and Configuring PostgreSQL Server 9.5

Describe the issue: 

On step 5, the path for pg_hba.conf looks wrong 
/var/lib/pgsql/data/pg_hba.conf

Suggestions for improvement: 

This is usually
/var/opt/rh/rh-postgresql95/lib/pgsql/data/pg_hba.conf

------------------------
Section Number and Name: 

1.3.2. Installing and Configuring PostgreSQL Server 9.5

Describe the issue: 

On step 7, the "systemctl enable..." command is unnecessary. Is a typo.

Suggestions for improvement: 

Delete the line.

------------------------
Section Number and Name: 

2.1. INSTALL AND CONFIGURE CASSANDRA

Describe the issue: 

On step 1, the docker command, has an undesirable linefeed after the "Z" which produces an error when copy pasting

Suggestions for improvement: 

Delete the linefeed to ensure the command is just one line.

------------------------
Section Number and Name: 

2.2. STARTING THE MIDDLEWARE MANAGER SERVICES

Describe the issue: 

2 lines of docker command require to be finished with "\"
      -e HAWKULAR_INVENTORY.....
      --link=mwmanager-cassandra

Suggestions for improvement: 

add the "\" at the end of each line

Comment 1 mario.mendoza 2017-01-27 02:09:38 UTC
*** Bug 1417022 has been marked as a duplicate of this bug. ***

Comment 2 Paul Gier 2017-01-31 22:17:41 UTC
I sent a pull request to the github docs to fix the issues in the postgresql install instructions and improve the formatting in the cassandra install note.
https://github.com/hawkular/hawkular-docs/pull/13

And it looks like the issue in section 2.2 has already been fixed in github:
https://github.com/hawkular/hawkular-docs/commit/e75e4b57439a2fb73eefcb9424d0230a97e76970

Comment 3 Andrew Dahms 2017-01-31 23:35:52 UTC
*** Bug 1410210 has been marked as a duplicate of this bug. ***

Comment 6 Prachi 2017-02-14 17:50:19 UTC
1) 
************************
1.3.2. Installing and Configuring PostgreSQL Server 9.5

Describe the issue: 

On step 5, the path for pg_hba.conf looks wrong 
/var/lib/pgsql/data/pg_hba.conf

Suggestions for improvement: 

This is usually
/var/opt/rh/rh-postgresql95/lib/pgsql/data/pg_hba.conf
************************

Document edited as per suggestion 

2)

************************
1.3.2. Installing and Configuring PostgreSQL Server 9.5

Describe the issue: 

On step 7, the "systemctl enable..." command is unnecessary. Is a typo.

************************

systemctl enable rh-postgresql95-postgresql is still present.

3) 
***********************
 INSTALL AND CONFIGURE CASSANDRA

Describe the issue: 

On step 1, the docker command, has an undesirable linefeed after the "Z" which produces an error when copy pasting

Suggestions for improvement: 

Delete the linefeed to ensure the command is just one line.
***********************

Z is still present and the verification is also provided in the document. The Z option is necessary on Red Hat Enterprise Linux/Fedora based systems to correctly set the SELinux permissions. 

4)

***********************
STARTING THE MIDDLEWARE MANAGER SERVICES

Describe the issue: 

2 lines of docker command require to be finished with "\"
      -e HAWKULAR_INVENTORY.....
      --link=mwmanager-cassandra

Suggestions for improvement: 

add the "\" at the end of each line
***********************

Edited as per suggestion.

Comment 7 jstickle 2017-02-14 18:48:30 UTC
2)  1.3.2. Installing and Configuring PostgreSQL Server 9.5

Describe the issue: 

On step 7, the "systemctl enable..." command is unnecessary. Is a typo.

*****

Worked with Matt Mahoney on 2/7/17 to determine the correct commands for installing and configuring PostgreSQL server.  Verified that the 'systemctl enable..." command is not a typo and is required as part of the configuration steps.  We should have documented that here for QE.

Comment 9 mario.mendoza 2017-02-15 00:04:48 UTC
(In reply to jstickle from comment #7)
> 2)  1.3.2. Installing and Configuring PostgreSQL Server 9.5
> 
> Describe the issue: 
> 
> On step 7, the "systemctl enable..." command is unnecessary. Is a typo.
> 
> *****
> 
> Worked with Matt Mahoney on 2/7/17 to determine the correct commands for
> installing and configuring PostgreSQL server.  Verified that the 'systemctl
> enable..." command is not a typo and is required as part of the
> configuration steps.  We should have documented that here for QE.

I'm sure this is a typo because the command:

  systemctl enable rh-postgresql95-postgresql.service

is previously ran on step 2  (which is correct)
but is duplicated on steps 7  (this is a typo)

The comand: "systemctl enable xxxx" 
means: "the service xxxx must be started automatically during the system start up, from now onwards"

So you don't need to execute it twice, it has no sense.

Comment 10 mario.mendoza 2017-02-15 00:11:42 UTC
(In reply to Prachi from comment #6)
> 
> 3) 
> ***********************
>  INSTALL AND CONFIGURE CASSANDRA
> 
> Describe the issue: 
> 
> On step 1, the docker command, has an undesirable linefeed after the "Z"
> which produces an error when copy pasting
> 
> Suggestions for improvement: 
> 
> Delete the linefeed to ensure the command is just one line.
> ***********************
> 
> Z is still present and the verification is also provided in the document.
> The Z option is necessary on Red Hat Enterprise Linux/Fedora based systems
> to correctly set the SELinux permissions. 
> 

The problem is not about the "Z" 

The problem is that AFTER the "Z" there is an undesirable linefeed which splits the command line in two

Comment 11 jstickle 2017-02-23 21:16:40 UTC
Mario - Thanks for the clarification about your comment on step 7.  That did get fixed when Matt and I rewrote the PostgreSQL installation instructions.  The doc no longer has you execute the 'enable' command twice.  

Also the linefeed after the "Z" has been removed.


Note You need to log in before you can comment on or make changes to this bug.