Bug 1417281 - '<pre-hashed password>' terminology is misleading
Summary: '<pre-hashed password>' terminology is misleading
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 19:11 UTC by Ian Tewksbury
Modified: 2018-04-24 15:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 15:59:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ian Tewksbury 2017-01-27 19:11:30 UTC
Document URL: 

https://github.com/openshift/openshift-ansible/blob/master/inventory/byo/hosts.ose.example#L123

Section Number and Name: 

N/A. In example hosts.ose.example

Describe the issue: 

https://github.com/openshift/openshift-ansible/blob/master/inventory/byo/hosts.ose.example#L123

#openshift_master_htpasswd_users={'user1': '<pre-hashed password>', 'user2': '<pre-hashed password>'}

The term "pre-hashed password" is confusing. It sounds like a password "pre" as in "before" hashed. As in "clear text password". Looking at the doc it is a hashed password. 

Suggestions for improvement: 

This should just be updated to be '<hashed password>'.

Additional information: 

Git issue: https://github.com/openshift/openshift-ansible/issues/3212

Comment 1 Gaurav Nelson 2018-04-24 15:59:08 UTC
Not a bug in ocp docs


Note You need to log in before you can comment on or make changes to this bug.