Bug 1417304 - awscli has a broken dependency on python-docutils
Summary: awscli has a broken dependency on python-docutils
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: awscli
Version: epel7
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabio Alessandro Locati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 21:35 UTC by Trevin Beattie
Modified: 2017-02-06 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 16:49:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Trevin Beattie 2017-01-27 21:35:20 UTC
Description of problem:
I'm unable to install the awscli package from EPEL 7-9 on a Red Hat EL 7.3 server in AWS.  yum says the package requires python-docutils >= 0.10, but python-docutils is not in any available repository.

The repository list includes: epel/x86_64, rhui-REGION-client-config-server-7/x86_64, rhui-REGION-rhel-server-releases/7Server/x86_64, and rhui-REGION-rhel-server-rh-common/7Server/x86_64.

Version-Release number of selected component (if applicable):
1.11.28-2.el7

How reproducible:
Always

Steps to Reproduce:
1. yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
2. yum install awscli

Actual results:
Error: Package: python2-botocore-1.5.3-1.el7.noarch (epel-testing)
           Requires: python-docutils >= 0.10
Error: Package: awscli-1.11.40-1.el7.noarch (epel-testing)
           Requires: python-docutils >= 0.10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Dependencies Resolved

Additional info:
After reading bug 1380536 I also tried adding the option "--enablerepo=epel-testing", but python-docutils was not in that repository either.

Comment 1 Trevin Beattie 2017-01-30 16:22:12 UTC
Forgot to include a step, implied in the description, but it may be important.

0. Launch an instance of “Red Hat Enterprise Linux 7.3 (HVM)” (ami-6f68cf0f) in Amazon EC2.

Comment 2 Trevin Beattie 2017-02-06 16:49:53 UTC
I just happened to try this again on another instance that was using an older AMI, RHEL-7.2_HVM_GA-20151112-x86_64-1-Hourly2-GP2 (ami-775e4f16), and it found the dependency in the rhui-REGION-rhel-server-optional repository.  Checking the repo configurations I found that this repository is enabled on the RH 7.2 instance, but _disabled_ on the RH 7.3 instance.  So it appears this is not actually a broken dependency, but a repository misconfiguration.

Not sure whether that can be called a fault on the RHEL side or on EPEL, but I can work around it by adding "yum-config-manager --enable rhui-REGION-rhel-server-optional" to the launch script.


Note You need to log in before you can comment on or make changes to this bug.