Bug 141731 - eth0 dies after bridg'n to pan0(bnep0)
eth0 dies after bridg'n to pan0(bnep0)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bluez-pan (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 07:37 EST by Kamen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 07:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamen 2004-12-03 07:37:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a;
MultiZilla v1.1.32 final) Gecko/20021211

Description of problem:
Following the instructions from :
http://bluez.sourceforge.net/contrib/HOWTO-PAN

my network connection dies after typing "brctl addif pan0 eth0".
The exact sequence :

brctl addbr pan0
ifconfig pan0 192.168.1.1
brctl setfd pan0 0
brctl stp pan0 disable
brctl addif pan0 eth0 <---- HERE is dead

I have to do "brctl delif pan0 eth0" to restore it again.

In /var/log/messages I get :

pan0: port 2(eth0) entering learning state
kernel: pan0: port 2(eth0) entering forwarding state
kernel: pan0: topology change detected, propagating
kernel: pan0: port 2(eth0) entering disabled state


Version-Release number of selected component (if applicable):
kernel-2.4.20-37.9.legacy

How reproducible:
Always

Steps to Reproduce:
1.Create bluetooth net connection (NAP)
2.ifconfig  - here bnep0 appears with a valid network address 192.168.0.10
3.brctl addbr pan0
4.ifconfig pan0 192.168.1.1
5.brctl setfd pan0 0
6.brctl stp pan0 disable
7.brctl addif pan0 eth0 <---- HERE is dead

    

Actual Results:  I have no network connection at all. My machine is
not visible from outside, I cannot reach anything.

Expected Results:  I should have bridge between eth0 and bnep0 devices. 
I should be able to browse from my PDA over this netwok connection.

Additional info:

I'm using bluez-utils-2.10-2.0.rh90.kde
Comment 1 David Woodhouse 2005-03-02 07:03:51 EST
This looks like a networking configuration or kernel problem. PAN appears to
have been working. Fedora initscripts should handle this a lot better nowadays.

Note You need to log in before you can comment on or make changes to this bug.