Bug 1417486 - dnf fails to update okular because of libqmobipocket
Summary: dnf fails to update okular because of libqmobipocket
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kfilemetadata
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 19:47 UTC by Peter Gervase
Modified: 2017-01-29 22:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-29 22:37:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Gervase 2017-01-29 19:47:47 UTC
Description of problem:
I tried doing a dnf update and it failed. I tried updating a single package at a time to see what the issue was and I found there is an issue with kdegraphics-mobipocket and okular. 
$ sudo dnf update okular-part
Last metadata expiration check: 0:19:08 ago on Sun Jan 29 14:15:14 2017 EST.
Failed to synchronize cache for repo 'beaker', disabling.
Dependencies resolved.
=============================================================================================================================================================================================
 Package                                                Arch                                   Version                                         Repository                               Size
=============================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 kdegraphics-mobipocket                                 x86_64                                 16.12.1-1.fc26                                  rawhide                                  39 k
 okular                                                 x86_64                                 16.12.1-1.fc26                                  rawhide                                 760 k
 okular-libs                                            x86_64                                 16.12.1-1.fc26                                  rawhide                                 305 k
 okular-part                                            x86_64                                 16.12.1-1.fc26                                  rawhide                                 970 k

Transaction Summary
=============================================================================================================================================================================================
Skip  4 Packages

Nothing to do.
Complete!



I downloaded the rpms from the repo and then used rpm to try installing them:
$ sudo rpm -Uvh /data/downloads/okular-16.12.1-1.fc26.x86_64.rpm /data/downloads/okular-part-16.12.1-1.fc26.x86_64.rpm /data/downloads/okular-libs-16.12.1-1.fc26.x86_64.rpm 
error: Failed dependencies:
        libqmobipocket.so.2()(64bit) is needed by okular-part-16.12.1-1.fc26.x86_64



I then tried using dnf to install kdegraphics-mobipocket:
$ sudo dnf install kdegraphics-mobipocket
Last metadata expiration check: 0:21:32 ago on Sun Jan 29 14:15:14 2017 EST.
Failed to synchronize cache for repo 'beaker', disabling.
Error: conflicting requests
  - package kdegraphics-mobipocket-16.12.1-1.fc26.i686 obsoletes qmobipocket < 16.12.0 provided by qmobipocket-16.08.3-1.fc26.x86_64
  - package kdegraphics-mobipocket-16.12.1-1.fc26.x86_64 obsoletes qmobipocket < 16.12.0 provided by qmobipocket-16.08.3-1.fc26.x86_64
  - package kdegraphics-mobipocket-16.12.1-1.fc26.i686 obsoletes qmobipocket < 16.12.0 provided by qmobipocket-16.08.3-1.fc26.x86_64
  - package kdegraphics-mobipocket-16.12.1-1.fc26.x86_64 obsoletes qmobipocket < 16.12.0 provided by qmobipocket-16.08.3-1.fc26.x86_64
  - problem with installed package kfilemetadata-4.14.3-5.fc24.x86_64
  - package kfilemetadata-4.14.3-5.fc24.x86_64 requires libqmobipocket.so.1()(64bit), but none of the providers can be installed
  - package kfilemetadata-4.14.3-5.fc24.x86_64 requires libqmobipocket.so.1()(64bit), but none of the providers can be installed
  - package kfilemetadata-4.14.3-5.fc24.x86_64 requires libqmobipocket.so.1()(64bit), but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)


Looking at the kdegraphics-mobipocket rpm, we see that it has been updated but the dependency hasn't:
$ rpm -qp --provides /data/downloads/kdegraphics-mobipocket-16.12.1-1.fc26.x86_64.rpm 
kdegraphics-mobipocket = 16.12.1-1.fc26
kdegraphics-mobipocket(x86-64) = 16.12.1-1.fc26
libqmobipocket.so.2()(64bit)
qmobipocket = 16.12.1-1.fc26
qmobipocket(x86-64) = 16.12.1-1.fc26




From the error above, we see
  - package kfilemetadata-4.14.3-5.fc24.x86_64 requires libqmobipocket.so.1()(64bit), but none of the providers can be installed

and the kdegraphics-mobipocket provides libqmobipocket.so.2()(64bit)


Version-Release number of selected component (if applicable):
$ rpm -qa okular* *mobipocket*
okular-16.08.3-1.fc26.x86_64
okular-part-16.08.3-1.fc26.x86_64
okular-libs-16.08.3-1.fc26.x86_64
qmobipocket-16.08.3-1.fc26.x86_64

kdegraphics-mobipocket-16.12.1-1.fc26.x86_64.rpm 
kfilemetadata-4.14.3-5.fc24.x86_64

How reproducible:
100%

Steps to Reproduce:
1. dnf clean all
2. dnf update
3.

Actual results:
errors as shown above

Expected results:
dependencies resolved and update completed.

Additional info:

Comment 1 Rex Dieter 2017-01-29 22:32:45 UTC
It's kfilemetadata holding the update back.


%changelog
* Sun Jan 29 2017 Rex Dieter <rdieter@fedoraproject.org> - 4.14.3-6
- rebuild (qmobipocket)


That said, looks like nothing in fedora depends on kfilemetadata anymore, so perhaps we can retire it.

Comment 2 Fedora Admin XMLRPC Client 2017-01-29 22:35:48 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.