Bug 141771 - missing / in xml breaks ide-drives.fdi
missing / in xml breaks ide-drives.fdi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 12:49 EST by Sarantis Paskalis
Modified: 2013-03-05 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 14:15:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hald-before.log (111.27 KB, text/plain)
2004-12-03 12:52 EST, Sarantis Paskalis
no flags Details
patch for ide-drives.fdi (204 bytes, patch)
2004-12-03 12:55 EST, Sarantis Paskalis
no flags Details | Diff
hald-after.log (98.99 KB, text/plain)
2004-12-03 12:58 EST, Sarantis Paskalis
no flags Details

  None (edit)
Description Sarantis Paskalis 2004-12-03 12:49:30 EST
Description of problem:
Trying hald --verbose=yes --daemon=no yield many errors in
ide-drives.fdi.  Obvious reason is a missing / in <device> line 50,
column 2.

Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
always

Steps to Reproduce:
1. run hald --verbose=yes daemon=no
2. check output
3.
  
Actual results:
errors exist in log

Expected results:
no errors should exist

Additional info:
I am really not sure if this is something serious.  I am trying to
debug another problem of mine, because it refuses to mount any
removable devices (cdrom, usb memory sticks) as a non-root user.
Comment 1 Sarantis Paskalis 2004-12-03 12:52:20 EST
Created attachment 107851 [details]
hald-before.log

Attached a log with the behaviour before the patch
Comment 2 Sarantis Paskalis 2004-12-03 12:55:36 EST
Created attachment 107855 [details]
patch for ide-drives.fdi

Mini patch for correcting ide-drives.fdi
Comment 3 Sarantis Paskalis 2004-12-03 12:58:52 EST
Created attachment 107856 [details]
hald-after.log

Attached a log with the behaviour after the patch
Comment 4 David Zeuthen 2005-01-13 14:15:45 EST
Fixed in hal-0.4.5 - available in Rawhide and as a FC3 update.

Thanks,
David

Note You need to log in before you can comment on or make changes to this bug.