Bug 141781 - Installation with LVM on RAID1 fails
Installation with LVM on RAID1 fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 145948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 13:46 EST by Charles Lopes
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:13:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/lvmout (718 bytes, text/plain)
2004-12-06 12:45 EST, Charles Lopes
no flags Details
Kickstart file used when problem was experienced (1.72 KB, text/plain)
2004-12-06 12:49 EST, Charles Lopes
no flags Details

  None (edit)
Description Charles Lopes 2004-12-03 13:46:59 EST
Installing LVM on top of RAID1 arrays makes anaconda dies because of a
failed lvcreate. This seems caused by "/etc/lvm/lvm.conf" setting
"md_component_detection" to 0. Having it set to 1 solves the problem.
The comment in lvm.py seems to indicate that the filtering breaks
things . Not filtering breaks LVM on RAID1.
Comment 1 Jeremy Katz 2004-12-06 11:12:53 EST
This doesn't cause failures here.  What are the messages in
/tmp/lvmout for when the lvcreate fails?
Comment 2 Charles Lopes 2004-12-06 12:45:32 EST
Created attachment 107971 [details]
/tmp/lvmout
Comment 3 Charles Lopes 2004-12-06 12:49:31 EST
Created attachment 107972 [details]
Kickstart file used when problem was experienced
Comment 4 Charles Lopes 2004-12-06 12:53:48 EST
I attached as well a kickstart file that shows what I was trying to
do. A manual installation exhibits the same problem. At the moment I
solved it by editing lvm.py and respining a new set of .img files. I
hope this helps.
Comment 5 Paul Nasrat 2004-12-09 14:52:48 EST
Just to let you know I've reproduced here, and am investigating further.
Comment 6 Donavan Kienenberger 2004-12-12 18:12:51 EST
I may have a problem related to this. I was installing from CD, I
received the following Exception error during the installation:

Exception Occured
Traceback (most recent call last:)
File: "/usr/src/build/475969-i386/install//user/lib/anaconda/gui.py",
line 1074, in handleRenderCallBack self.currentWindow.renderCallback()
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/wi/progres_gui.py",
line 242, in renderCallBack self.intf.icw.nextClicked()
File: "/usr/src/build/475969-i386/install//user/lib/anaconda/gui.py",
line 789, in nextClicked self.dispach.gotoNext()
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/dispatch.py",
line 171, in gotoNext self.moveStep()
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/dispatch.py",
line 239, in moveStep rc=apply(func, self.bindArgs(args))
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/packages.py",
line 554, in turnOnFilesystems thefsset.createLogicalVolumes(instPath))
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/fsset.py", line
1432, in createLogicalVolumes entry.device.setupDevice(chroot)
File:
"/usr/src/build/475969-i386/install//user/lib/anaconda/fsset.py", line
2051, in setupDevice raise SystemError, "lvcreate failed for %s"
%(self.name,)
SystemError: lvcreate failed for system


Here is my drive setup using Disk Druid:

Drive /dev/hda 238473 MB
Drive /dev/hdc 238473 MB

LBVM Volume Groups:
filesystem   size: 238336
system  mp:/  type:ext3  size:237312
swap  type:swap  1024

RAID Devices:
/dev/md1  mp:/boot  type:ext3  size: 101.944
/dev/md2  mp:filesystem  type:LVM PV  size:238371

HARD DRIVES:
/dev/hda:
/dev/hda1  mp:/dev/md1  type:softwareRAID  size:102  start:1 end:13
/dev/hda2  mp:/dev/md2  type:softwareRAID  size:238371  start:14 end:30401
/dev/hdc:
/dev/hdc1  mp:/dev/md1  type:softwareRAID  size:102  start:1 end:13
/dev/hdc2  mp:/dev/md2  type:softwareRAID  size:238371  start:14 end:30401

The install terminates and unmounts file systems before I can get to
any of the logs.
Comment 7 Paul Nasrat 2004-12-14 13:39:09 EST
Commited md_component_detection=1
Comment 8 Jeremy Katz 2005-01-24 13:45:11 EST
*** Bug 145948 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.