Bug 141782 - Want special prompt for root when using (t)csh
Summary: Want special prompt for root when using (t)csh
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rootfiles (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-03 18:47 UTC by Toralf
Modified: 2014-03-17 02:51 UTC (History)
1 user (show)

Fixed In Version: 8.1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 21:43:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toralf 2004-12-03 18:47:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After upgrading to Fedora Core 3, I no longer get a special prompt
when I log in as root, and the user is configured with /bin/tcsh as
shell - I get the same setting as a regular tcsh user. Provided that
none of the users have set up custom prompts in .cshrc or similar, of
course.

Yeah, I know - the user name is actually displayed in the prompt, but
I'd still like something more distinct, or should I say more familiar,
for root (I'm getting confused without it.)

Suggestion: Use

'[%n@%m %c]# '

for root where the default for other users is

'[%n@%m %c]$ '

Version-Release number of selected component (if applicable):
2.5.36-1

Comment 1 Bill Nottingham 2004-12-03 21:11:11 UTC
Did this work in any previous release (from your first comment, I'm
not sure.)

Comment 2 Toralf 2004-12-03 21:32:13 UTC
OK I wasn't very clear here, and I also somehow got the impression
that there had been a change to the default prompt since, but now I
think that this is just something that has stopped working... I also
seemed to recall that a special test in the common startup files used
to make sure the root prompt was set up correctly, but again I was wrong.

The situation is this:

With Red Hat Linux 9, and I believe also Fedora Core 1 and 2, root
gets a special prompt simply because /root/.tcshrc installed by the
"rootfiles" package has the line

set prompt='[%n@%m %c]# '

In the Fedora core version, there is no such line.

Comment 3 Bill Nottingham 2004-12-03 21:43:52 UTC
Fixed in rootfiles-8.1-1


Note You need to log in before you can comment on or make changes to this bug.