This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 141792 - corrupt SRPM download via Mozilla
corrupt SRPM download via Mozilla
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
rhn360
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
:
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2004-12-03 15:02 EST by John Reiser
Modified: 2007-04-18 13:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 11:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-12-03 15:02:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
I tried to download kernel-2.4.21-20.0.1.EL.src.rpm (38,027,164 bytes)
by Shift-click on the link from 
https://rhn.redhat.com/network/software/packages/details.pxt?pid=287501
using mozilla-1.4.3-3.0.4, and got garbage.  The first thing that I
noticed was that the Download Manager did not know how long the file
was, and so did not indicate the download time remaining.  Then I
noticed that the byte count kept going beyond the stated length of
38,027,164 bytes; I received 45613691 bytes before I Canceled the
download.

Examining the downloaded file shows that the first 38027164 bytes look
like a good .src.rpm, and the immediately-following bytes are HTTP:
-----
$ dd if=kernel-2.4.21-20.0.1.EL.src.rpm bs=38027164 skip=1 count=1 |
od -Ax -tc - | sed 6q
000000   H   T   T   P   /   1   .   1       2   0   0       O   K  \r
000010  \n   D   a   t   e   :       F   r   i   ,       0   3       D
000020   e   c       2   0   0   4       1   9   :   3   6   :   3   4
000030       G   M   T  \r  \n   S   e   r   v   e   r   :       A   p
000040   a   c   h   e  \r  \n   C   o   n   t   e   n   t   -   d   i
000050   s   p   o   s   i   t   i   o   n   :       a   t   t   a   c
----

and in fact the complete "header" text is
-----
HTTP/1.1 200 OK^M
Date: Fri, 03 Dec 2004 19:36:34 GMT^M
Server: Apache^M
Content-disposition: attachment;
filename=kernel-2.4.21-20.0.1.EL.src.rpm^M
Set-Cookie:
pxt-session-cookie=1116535674xad7b7f7c72a208503540663c2dc20f2f;
domain=download.rhn.redhat.com; path=/; expires=Sun, 05-Dec-2004
19:36:34 GMT; secure^M
Set-Cookie:
rh_auth_token=1316294:1102102594x2a3f511492617a8a384a80e86703f9e9;
domain=.redhat.com; path=/; expires=Sun, 05-Dec-2004 19:36:34 GMT^M
Content-Length: 38027164^M
Content-Type: application/octet-stream^M
Via: 1.1 download.rhn.redhat.com^M
Last-Modified: Thu, 02 Dec 2004 09:29:54 GMT^M
ETag: "f67c16-2443f9c-41aee092"^M
Accept-Ranges: bytes^M
Keep-Alive: timeout=15, max=99^M
Connection: Keep-Alive^M
Content-Language: el^M

-----
and after that it looks like another copy of the .src.rpm binary bytes.


Version-Release number of selected component (if applicable):
rhn-3.6.0

How reproducible:
Didn't try

Steps to Reproduce:
1.visit
https://rhn.redhat.com/network/software/packages/details.pxt?pid=287501
using mozilla-1.4.3-3.0.4
2. Shift-click on link for kernel-2.4.21-20.0.1.EL.src.rpm (38,027,164
bytes)      Download SRPM

3. watch Download manager
    

Actual Results:  1. Length is Unknown, and so there is no estimate of
remaining download time.
2. Downloaded byte count continues beyond stated length of 38,027,164
bytes.

Expected Results:  1. Download Manager knows the length, and so
displays expected time remaining.
2. Correct size of 38,027,164 bytes downloaded, then stopped.

Additional info:
Comment 1 Chip Turner 2004-12-03 15:21:50 EST
How repeatable is this for you?  I am unable to reproduce.
Comment 2 John Reiser 2004-12-03 16:20:29 EST
Yes, I just reproduced it [took a while at 15.0 KB/s].  The "header"
lines beginning at byte 38,027,164 now say
-----
HTTP/1.1 200 OK
Date: Fri, 03 Dec 2004 21:09:53 GMT
Server: Apache
Content-disposition: attachment; filename=kernel-2.4.21-20.0.1.EL.src.rpm
Set-Cookie:
pxt-session-cookie=1116535674xad7b7f7c72a208503540663c2dc20f2f;
domain=download.rhn.redhat.com; path=/; expires=Sun, 05-Dec-2004
21:09:53 GMT; secure
Set-Cookie:
rh_auth_token=1316294:1102108193x6e637147ae3b43a15abbcdfde472cf25;
domain=.redhat.com; path=/; expires=Sun, 05-Dec-2004 21:09:53 GMT
Content-Length: 38027164
Content-Type: application/octet-stream
Via: 1.1 download.rhn.redhat.com
Last-Modified: Thu, 02 Dec 2004 09:29:54 GMT
ETag: "f67c16-2443f9c-41aee092"
Accept-Ranges: bytes
Keep-Alive: timeout=15, max=99
Connection: Keep-Alive
Content-Language: el
                                                                     
                                 
-----

This is running kernel-2.4.21-20.0.1.EL.i686 on RHEL3 WS;  the
original was running kernel-2.4.21-20.EL.i686 on the same system.  In
both cases "rpm -ql -p " on the downloaded file [truncated to the
proper length by using dd] gives a list of files and does not complain.
Comment 3 Mihai Ibanescu 2005-05-17 11:58:11 EDT
I believe this is a case of double-headers that was fixed as of Apr 2005. Please
feel free to reopen if it still appears.

Note You need to log in before you can comment on or make changes to this bug.