Bug 1418001 - [abrt] geoclue2: g_variant_type_info_check(): geoclue killed by SIGABRT
Summary: [abrt] geoclue2: g_variant_type_info_check(): geoclue killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1400369
Alias: None
Product: Fedora
Classification: Fedora
Component: geoclue2
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zeeshan Ali
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d156eb9aa3943722b0b4f88bc1c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 14:56 UTC by Niko
Modified: 2017-01-31 17:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 17:08:49 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (37.52 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: cgroup (232 bytes, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: core_backtrace (11.20 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: dso_list (4.92 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: environ (282 bytes, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: limits (1.29 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: maps (22.96 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: mountinfo (3.66 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: namespaces (102 bytes, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: open_fds (621 bytes, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: proc_pid_status (1.09 KB, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details
File: var_log_messages (474 bytes, text/plain)
2017-01-31 14:56 UTC, Niko
no flags Details

Description Niko 2017-01-31 14:56:26 UTC
Version-Release number of selected component:
geoclue2-2.4.4-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/geoclue -t 5
crash_function: g_variant_type_info_check
executable:     /usr/libexec/geoclue
global_pid:     3001
kernel:         4.9.3-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            992

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 g_variant_type_info_check at gvarianttypeinfo.c:184
 #5 g_variant_type_info_get_type_string at gvarianttypeinfo.c:198
 #6 g_variant_is_of_type at gvariant.c:2107
 #7 valid_format_string at gvariant.c:4540
 #8 g_variant_get at gvariant.c:5381
 #9 gclue_service_location_get_property at gclue-service-location.c:99
 #10 object_get_property at gobject.c:1378
 #11 g_object_get_valist at gobject.c:2234
 #12 g_object_get at gobject.c:2324
 #13 distance_below_threshold at gclue-service-client.c:128

Comment 1 Niko 2017-01-31 14:56:33 UTC
Created attachment 1246322 [details]
File: backtrace

Comment 2 Niko 2017-01-31 14:56:35 UTC
Created attachment 1246323 [details]
File: cgroup

Comment 3 Niko 2017-01-31 14:56:37 UTC
Created attachment 1246324 [details]
File: core_backtrace

Comment 4 Niko 2017-01-31 14:56:39 UTC
Created attachment 1246325 [details]
File: dso_list

Comment 5 Niko 2017-01-31 14:56:40 UTC
Created attachment 1246326 [details]
File: environ

Comment 6 Niko 2017-01-31 14:56:42 UTC
Created attachment 1246327 [details]
File: limits

Comment 7 Niko 2017-01-31 14:56:44 UTC
Created attachment 1246328 [details]
File: maps

Comment 8 Niko 2017-01-31 14:56:46 UTC
Created attachment 1246329 [details]
File: mountinfo

Comment 9 Niko 2017-01-31 14:56:48 UTC
Created attachment 1246330 [details]
File: namespaces

Comment 10 Niko 2017-01-31 14:56:49 UTC
Created attachment 1246331 [details]
File: open_fds

Comment 11 Niko 2017-01-31 14:56:51 UTC
Created attachment 1246332 [details]
File: proc_pid_status

Comment 12 Niko 2017-01-31 14:56:52 UTC
Created attachment 1246334 [details]
File: var_log_messages

Comment 13 Niko 2017-01-31 15:02:31 UTC
maybe related to bug 1417998

Comment 14 Zeeshan Ali 2017-01-31 17:08:49 UTC
(In reply to Niko from comment #13)
> maybe related to bug 1417998

Backtrace is completely different so I doubt so but this is very likely a duplicate of bug#1400369.

*** This bug has been marked as a duplicate of bug 1400369 ***


Note You need to log in before you can comment on or make changes to this bug.