Bug 1418290 - wrong error when removing pool
Summary: wrong error when removing pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.1.3
: ---
Assignee: Shmuel Melamud
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 1433983 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 13:30 UTC by Lucie Leistnerova
Modified: 2018-01-21 20:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-06 13:56:51 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
mtessun: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 76163 master MERGED core: Set action message parameters in RemoveVmPoolCommand 2017-04-27 14:59:28 UTC
oVirt gerrit 76245 ovirt-engine-4.1 MERGED core: Set action message parameters in RemoveVmPoolCommand 2017-05-01 12:26:24 UTC

Description Lucie Leistnerova 2017-02-01 13:30:11 UTC
Description of problem:
When I try to remove pool that is still creating VMs error contains variable names not the values.

Cannot ${action} ${type}. This VM Pool is currently in use to create VM ${VmName}.


Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.3-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. create pool with more then 10 VMs
2. try to remove the pool when the VMs are still creating

Actual results: dialog pops up and error contains variables instead of values


Expected results: error is right

Comment 1 Lucie Leistnerova 2017-02-01 13:33:41 UTC
Also when I try to remove pool that is already removing error is

Cannot ${action} ${type}. VM pool ${VmPoolName} is being removed with VM ${VmName}.

Comment 3 Lucie Leistnerova 2017-06-01 06:39:15 UTC
Both errors are correct now.

verified in ovirt-engine-webadmin-portal-4.1.3-0.1.el7.noarch

Comment 4 Shmuel Melamud 2018-01-21 20:35:40 UTC
*** Bug 1433983 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.