Bug 1418299 - [RFE] add detailed message to events when creating pool from template with cinder disk crashes because of maxium volumes exceeded
Summary: [RFE] add detailed message to events when creating pool from template with ci...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: bugs@ovirt.org
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 13:52 UTC by Lucie Leistnerova
Modified: 2018-11-14 11:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-14 11:25:00 UTC
oVirt Team: Virt
mtessun: ovirt-4.4?
mtessun: planning_ack+
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine_log (15.60 KB, text/plain)
2017-02-01 13:52 UTC, Lucie Leistnerova
no flags Details

Description Lucie Leistnerova 2017-02-01 13:52:18 UTC
Created attachment 1246652 [details]
engine_log

Description of problem:
The process of creating VMs stops when I create pool from template with cinder disk and try to remove it when the VMs are still creating.

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. create template with cinder disk
2. create pool with more than 10 VMs from the template
3. try to remove the pool when the VMs are still creating, confirm it

Actual results: popup dialog shows with error and VMs stops to create


Expected results: error is shown and VMs continue to create until number in the pool is reached

Comment 1 Lucie Leistnerova 2017-02-01 13:53:00 UTC
Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.3-0.1.el7.noarch

Comment 2 Lucie Leistnerova 2017-02-01 15:29:27 UTC
I tested cinder pool on other engine and the problem is not in removing the pool. Vms stop to create because cinder service can no longer create disks.

When I create only one disk then engine says

Cannot add Virtual Disk. Maximum number of volumes allowed (10) exceeded - could not create Cinder disks on Storage Domain tlv_cinder.

So it should say the same when creating VMs in pool.
In events is only 
Not all VMs where successfully created in VM Pool __pool??.
Failed to create VM Pool __pool?? (User: admin@internal-authz).

Comment 4 Yaniv Kaul 2017-06-06 21:59:00 UTC
(In reply to Lucie Leistnerova from comment #2)
> I tested cinder pool on other engine and the problem is not in removing the
> pool. Vms stop to create because cinder service can no longer create disks.
> 
> When I create only one disk then engine says
> 
> Cannot add Virtual Disk. Maximum number of volumes allowed (10) exceeded -

Where did we get such a low (10) number?

Comment 7 Ryan Barry 2018-11-14 11:25:00 UTC
This will not make it in a reasonable time. Please re-open if you still feel this should be fixed


Note You need to log in before you can comment on or make changes to this bug.