Bug 141846 - boost-devel is removed when updating.
Summary: boost-devel is removed when updating.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-04 00:09 UTC by Niels Basjes
Modified: 2013-08-09 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 04:18:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Niels Basjes 2004-12-04 00:09:08 UTC
Description of problem:

Initial situation:

# rpm -qa boost*
boost-1.31.0-9
boost-devel-1.31.0-9

Now I update the installed software

# yum update
....
Transaction Listing:
  Update: boost.i386 0:1.32.0-1.fc3
....
Other Transactions:
  Obsoleting: boost.i386 0:1.31.0-9 with boost.i386 0:1.32.0-1.fc3
  Obsoleting: boost-devel.i386 0:1.31.0-9 with boost.i386 0:1.32.0-1.fc3
....
Updated: .... boost.i386 0:1.32.0-1.fc3 ....
Obsoleted: boost.i386 0:1.31.0-9 boost-devel.i386 0:1.31.0-9
Complete!

So after the update:
# rpm -qa boost*
boost-1.32.0-1.fc3

Why was boost-devel removed ???
I had to reinstall boost-devel manually.

Comment 1 Benjamin Kosnik 2005-03-16 04:18:35 UTC
This was fixed in later boost rpms, and was caused by an incorrect
Obsoletes line. 

best,
benjamin


Note You need to log in before you can comment on or make changes to this bug.