Bug 141852 - Sound-devices /dev/dsp missing Kernel-smp#2.6.9-1.681_FC3
Sound-devices /dev/dsp missing Kernel-smp#2.6.9-1.681_FC3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 20:17 EST by John Pover
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 05:25:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Pover 2004-12-03 20:17:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After upgrading from fc2->fc3 with the cd-set on dual Athlon
smp-machines (Tyan Thunder K7 1800+ and Thunder K7X 2600+) I find that
the /dev/dsp and /dev/mixer devices are missing. These can be produced
by running "/sbin/MAKEDEV sound" but even with that no audible sound.
On other (single Intel P-III and P-IV processors with
Kernel#2.6.9-1.681_FC3) machines these devices are present and sound
works as it supposed to do.

All software is updated to the last version by apt-get. No other
sound-cards or TV-capture-cards other than Creative Audigy LS cards
are present.
Yes, every slider is unmuted. 
Yes I have given the answer "Yes, I have heared the sound" after the
system-config-souncard soundcheck (even when I heared nothing). 
Reinstalling kernel-module-alsa/alsaconf/udev/hal etc does not change
this silence. 

Version-Release number of selected component (if applicable):
Kernel-smp#2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from FC2 to FC3 with the cd-set (not yum or apt-get)
2. Bring software up to date 
3. Reconfigue soundcard with alsaconf / system-config-soundcard
    

Actual Results:  No sound.

Expected Results:  Hear sound.

Additional info:

Upgrading from FC2 to FC3 should be possible and result in a working
system. I do not wont to go back to the dark ages of Linux when having
to start from scratch with every new release. Issues with xorg on
MatroxG550, no logging and no rebooting due to selinux, getting
RealPlayer to work, and finnaly this sound issue on SMP-machines have
cost me a full week so far. Thats enough.
Comment 1 Need Real Name 2004-12-04 07:19:54 EST
The recent updates of udev/hal etc had me wondering if perhaps
reinstalling kernel-smp-2.6.9-1.681_FC3 after these updates would
produce the missing devices (/dev/dsp & /dev/mixer). So I first booted
in to the original 2.6.9-1.667 FC3-kernel (only to see that the
devices are missing there aswell) and reinstalled 2.6.9-1.681_FC3 and
the kernel-modules and alsa. 

Synaptic produced a message after reinstalling
kernel-smp-2.6.9-1.681_FC3 :
"kernel-smp-2.6.9-1.681_FC3
WARNING:
/lib/modules/2.6.9-1.681_FC3smp/updates/sound/isa/wavefront/snd-wavefront.ko
needs unknown symbol sys_open"

Perhaps there is something with modutils was my next thought and
switched from modutils to mod-init-tools, and : Bingo, that produced
the /dev/dsp and /dev/mixer devices

Note You need to log in before you can comment on or make changes to this bug.