Bug 141855 - mouse wheel behaves poorly
mouse wheel behaves poorly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 21:27 EST by Charles Beyer
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 17:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Messages file from boot to problem occurance (32.28 KB, text/plain)
2004-12-06 23:46 EST, Charles Beyer
no flags Details
X11 conf file (2.81 KB, text/plain)
2004-12-06 23:47 EST, Charles Beyer
no flags Details

  None (edit)
Description Charles Beyer 2004-12-03 21:27:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:

Just installed Fedora Core 3.  The mouse behaves badly.  I updated and
it still behaves badly.

-- Under heavy disk/network I/O, it appears mouse events are lost. 
E.g., I have to click many times on something to get the click event
through.  Moving the mouse seems like MouseMotion events get lost too.

-- The most annoying thing is that when I scroll up on the mouse
wheel, it also triggers a right mouse button event, plus occasionally
another event because it constantly causes firefox to jump to home or
backware or forward.  Mouse wheel down works fine though.

I thought the problem went away with a single processor kernel, but it
reappeared while I was typing this bug report so I guess it isn't smp
kernel related.



Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21,  kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. boot
2. login under X
3. scroll up on the mouse-wheel
    

Actual Results:  Popup menus normally caused by a right click come up,
as well as a scroll up.

Additional info:

Mouse: Logitech Cordless Optical Mouse, connected to a Belkin PS/2 KVM
via a USB to PS/2 converter.

System: Tyan Thunder K7, dual athlonMP 1.2 Ghz cpus.

Mouse stuff in xorg.conf:

 InputDevice    "Mouse0" "CorePointer"
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
Comment 1 Mike A. Harris 2004-12-04 02:04:00 EST
Sounds more like a kernel issue than an X one.  Reassigning to
kernel component.
Comment 2 Charles Beyer 2004-12-04 11:43:21 EST
Additional Note:  The mouse doesn't behave strangely until after the
computer has been running for several minutes.  Does anyone have any
ideas on how I can track down the nature of the bug?

Looking at other bugs, maybe this is related to bug 123535?  On my
system, legacy USB support is disabled in the bios.
Comment 3 Mike A. Harris 2004-12-06 13:09:31 EST
Reboot your system, to ensure the hardware is fully reset.  After
the system comes up, start X normally, and try to invoke the
problematic behaviour.  Once the problem occurs, please make
a backup copy of your /var/log/messages from boot time onward
here.  Also attach your X server log and config file for completeness.

Please attach each as individual uncompressed file attachments using
the link below.
Comment 4 Charles Beyer 2004-12-06 23:46:08 EST
Created attachment 108017 [details]
Messages file from boot to problem occurance

For this boot, I noticed the mouse wheel start to throw bad events on a scroll
up at about 21:22.
Comment 5 Charles Beyer 2004-12-06 23:47:08 EST
Created attachment 108018 [details]
X11 conf file
Comment 6 Charles Beyer 2004-12-07 00:02:34 EST
I've tried running with APIC disabled in the bios, and also passing
noapic as an option to the kernel.  The system seems to run a bit
longer before the mouse starts acting up, but perhaps it just seems
that way because I'm watching it more closely.  

In any case, after some time the mouse-wheel-up starts generating bad
events, and I definately notice missing mouse-motion events when I'm
transfering files via scp.  I'm not maxing the bandwidth because it's
going over a cable-modem.  Also, I ran the scp from tty1 to make sure
it wasn't related to writing to the terminal.  Same behavior.

I did notice this in the earlier message log, thus prompting me to try
the noapic stuff:

I/O APIC: AMD Errata #22 may be present. In the event of instability
try booting with the "noapic" option.
Comment 7 Charles Beyer 2004-12-07 22:43:52 EST
After finding this article on the net:
    http://kerneltrap.org/node/view/2199
I change the protocol from "IMPS/2" to "ExplorerPS/2" and my mouse
behavior has improved significantly.  The mouse wheel seems to work
well now: it's been running for a day and hasn't thrown any spurious
events with this protocol.  

However, I'm still seeing the dropped events when I do some network
traffic like scp.  I loose mouse motion events, as well as mouse down
and mouse up events on all buttons.  When it gets into this state, I'm
probably loosing around 20-30% of the mouse events, which is bearable,
if ackward.
Comment 8 Dave Jones 2005-07-15 13:59:07 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 9 Charles Beyer 2005-07-24 09:47:56 EDT
I tried running with the news kernel with a non-SMP compile for a few days and
it seems to run fine.  However, The SMP kernel panics on me during boot so I am
unable to test that.  I suppose I should file a bug for that but instead I think
I'll just upgrade to fc4 in a few days and file bugs against that.

I'll be back.
Comment 10 Charles Beyer 2005-07-25 17:40:24 EDT
I'm going to change this to not-a-bug.

I connected the mouse to a second computer via a kvm switch and experienced the
same behavior with a Fedora Core 4 install.  Interestingly, when I setup the new
system to dual-boot with Windows XP, and fully updated the system, I experienced
the same erratic behavior with the mouse (although, only after I installed SP2).
 Irregardless, it must be some kind of hardware problem.

The mouse does behave alright under fc4 when I switch the protocol from "IMPS/2"
to "ExplorerPS/2".
Comment 11 Charles Beyer 2005-07-25 17:40:50 EDT
I'm going to change this to not-a-bug.

I connected the mouse to a second computer via a kvm switch and experienced the
same behavior with a Fedora Core 4 install.  Interestingly, when I setup the new
system to dual-boot with Windows XP, and fully updated the system, I experienced
the same erratic behavior with the mouse (although, only after I installed SP2).
 Irregardless, it must be some kind of hardware problem.

The mouse does behave alright under fc4 when I switch the protocol from "IMPS/2"
to "ExplorerPS/2".

Note You need to log in before you can comment on or make changes to this bug.