Bug 1418588 - changing Type in Volume form causes UI error
Summary: changing Type in Volume form causes UI error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Gobinda Das
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 09:28 UTC by Lucie Leistnerova
Modified: 2017-12-22 07:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:08:10 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2+
rule-engine: blocker+
rule-engine: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
volume ui error (97.96 KB, image/png)
2017-02-22 09:01 UTC, Lucie Leistnerova
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 70750 None None None 2017-02-22 11:21:15 UTC

Description Lucie Leistnerova 2017-02-02 09:28:47 UTC
Description of problem:
In Volume form changing value of Type to other than Distribution causes UI error.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.3-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. try to create new volume
2. change value of Type to Distributed Replicate

Actual results: UI error occurs


Expected results: no error and form changes as requested


Additional info:

ui.log
2017-02-02 09:18:36,290+01 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Permutation name: 7A9F3E72833E7B23A22BB4D11B47AC48
2017-02-02 09:18:36,291+01 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: qib(...) is undefined
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_121]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_121]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.logical.shared.ValueChangeEvent.fire(ValueChangeEvent.java:40) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.editor.ListModelListBox$2.execute(ListModelListBox.java:260)
	at com.google.gwt.core.client.impl.SchedulerImpl.runScheduledTasks(SchedulerImpl.java:164) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.$flushPostEventPumpCommands(SchedulerImpl.java:336) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl$Flusher.execute(SchedulerImpl.java:76) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.execute(SchedulerImpl.java:137) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.Qx/<(Unknown Source)
	at Unknown.zy/<(Unknown Source)
	at Unknown.sz/d<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: qib(...) is undefined
	at org.ovirt.engine.ui.uicommonweb.models.gluster.VolumeModel.$updateArbiterAvailability(VolumeModel.java:306)
	at org.ovirt.engine.ui.uicommonweb.models.gluster.VolumeModel$3.eventRaised(VolumeModel.java:150)
	at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:99)
	at org.ovirt.engine.ui.uicommonweb.models.ListModel.$setSelectedItem(ListModel.java:81)
	at org.ovirt.engine.ui.uicommonweb.models.ListModel.setSelectedItem(ListModel.java:77)
	at org.ovirt.engine.ui.webadmin.section.main.view.popup.gluster.VolumePopupView_typeList_selectedItem_Context.$setInModel(VolumePopupView_typeList_selectedItem_Context.java:19)
	at org.ovirt.engine.ui.webadmin.section.main.view.popup.gluster.VolumePopupView_typeList_selectedItem_Context.setInModel(VolumePopupView_typeList_selectedItem_Context.java:19)
	at org.ovirt.engine.ui.common.editor.UiCommonEditorVisitor.$setInModel(UiCommonEditorVisitor.java:180)
	at org.ovirt.engine.ui.common.editor.UiCommonEditorVisitor$1.onValueChange(UiCommonEditorVisitor.java:68)
	at com.google.gwt.event.logical.shared.ValueChangeEvent.dispatch(ValueChangeEvent.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 15 more

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-09 10:44:05 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Ramesh N 2017-02-20 11:00:09 UTC
I am not able to reproduce this bug in ovirt-4.1 branch. Can you confirm that you are able to re-produce this issue consistently?. May be the screenshot of the error or exact environment/steps to reproduce will help us analyze the issue further.

Comment 3 Lucie Leistnerova 2017-02-22 09:00:16 UTC
Yes, it happens all the time. I have the default installation with two hosts and one data storage.
Screenshot attached

Comment 4 Lucie Leistnerova 2017-02-22 09:01:04 UTC
Created attachment 1256380 [details]
volume ui error

Comment 5 Lucie Leistnerova 2017-02-22 09:45:46 UTC
I talked to Ramesh. The problem is only when there is no cluster with Gluster service enabled and creating Volume in this situation is not so common. Changing to medium severity.

Comment 6 Ramesh N 2017-02-22 11:21:16 UTC
This issue is already addressed in patch https://gerrit.ovirt.org/#/c/70750/

Comment 7 Red Hat Bugzilla Rules Engine 2017-04-17 08:51:48 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 8 Lucie Leistnerova 2017-08-31 11:50:33 UTC
no error

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170828065003.git0619c76.el7.centos.noarch

Comment 9 Sandro Bonazzola 2017-12-20 11:08:10 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.