Bug 1418605 - Dismissing "VM" stopped responding dialog with close button shuts down virt-manager
Summary: Dismissing "VM" stopped responding dialog with close button shuts down virt-m...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 10:28 UTC by Christophe de Dinechin
Modified: 2017-02-09 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-05 19:30:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Christophe de Dinechin 2017-02-02 10:28:05 UTC
Description of problem:

On a heavily loaded system, I ran into a case where a dialog box showed up for one of my VMs saying that it was not responding. There were two buttons, one of them being "Wait". I clicked on it, but this did not dismiss the dialog. So I clicked on the dialog's close box in the top-right, and this quit virt-manager. The VMs kept running, fortunately.


How reproducible:

1. Run a VM with a high load. In my case, building linux kernel at -j8 on a 4-VCPU machine.
2. Simultaneously run a high load on the host. In my case, building linux kernel at -j20 on a 8-CPU machine.
3. Wait until a message pops up indicating that the VM is not responsive.
4. Try to dismiss the dialog using the Wait button.
5. Try to dismiss the dialog using the dialog close button in top-right corner.


Actual results:

The Wait button has no visible effect. In my case, the VM was clearly running in the background.

The dialog close button closes the application.


Expected results:

The Wait button should dismiss the dialog and show the VM.
The dialog close button should do like Wait, and not close the application.

Comment 1 Cole Robinson 2017-02-05 19:30:28 UTC
Thanks for the report. That dialog comes from GTK, it automatically pops up when it detects that that the app is not responding for a few seconds, meaning it might be hung. The 'X' stopping the associated app is expected behavior as far as I know, so closing

You can try filing a bug about it against gtk but I'm certain they will say NOTABUG

Comment 2 Christophe de Dinechin 2017-02-06 10:03:42 UTC
I'm curious why the VM is seen as "hung" when it updates its display and responds to user input?

Comment 3 Cole Robinson 2017-02-09 22:18:21 UTC
(In reply to Christophe de Dinechin from comment #2)
> I'm curious why the VM is seen as "hung" when it updates its display and
> responds to user input?

Not sure, maybe due to the threading model of the spice-gtk widget. Is virt-manager responsive when the dialog pops up?


Note You need to log in before you can comment on or make changes to this bug.