This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 141869 - anaconda crash if selected layout has not enough space for installed packages
anaconda crash if selected layout has not enough space for installed packages
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-04 06:08 EST by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 12:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda "core" dump (702.40 KB, text/plain)
2004-12-04 06:10 EST, Arenas Belon, Carlo Marcelo
no flags Details
anaconda session log (20.54 KB, text/plain)
2004-12-04 06:11 EST, Arenas Belon, Carlo Marcelo
no flags Details

  None (edit)
Description Arenas Belon, Carlo Marcelo 2004-12-04 06:08:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041020 Firefox/0.10.1

Description of problem:
after realizing there is not enough disk space for installing the
selected list of packages, anaconda tries to go back by umounting all
directories but misses the "dev" mountpoint resulting on a fatal
exception while trying to umount the installation root.

attached anacdump.txt and anaconda.log showing the problem.

affects also fedora core 3 AFAIK and others which are using udev.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start installation
2. create a small /usr partition or select too many packages
3. proceed with the installation
    

Actual Results:  anaconda exception

Expected Results:  rollback to the package or partition selection

Additional info:
Comment 1 Arenas Belon, Carlo Marcelo 2004-12-04 06:10:10 EST
Created attachment 107889 [details]
anaconda "core" dump
Comment 2 Arenas Belon, Carlo Marcelo 2004-12-04 06:11:09 EST
Created attachment 107890 [details]
anaconda session log
Comment 3 Jeremy Katz 2004-12-04 12:33:28 EST
This is fixed since beta2 

Note You need to log in before you can comment on or make changes to this bug.