This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 141881 - knotes failed to resume after logout
knotes failed to resume after logout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-04 12:42 EST by Frank Wang
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: FC4/FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 18:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 90744 None None None Never
KDE Software Compilation 92596 None None None Never

  None (edit)
Description Frank Wang 2004-12-04 12:42:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
knotes can't resume correctly after logout, only a non-clickable 
vertical line filled rectangle icon box left in systray. 

Version-Release number of selected component (if applicable):
kdepim-3.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Start knotes and write anything in it
2. Logout
3. Login again
    

Actual Results:  A non-clickable  vertical line filled rectangle icon
box is left in systray

Expected Results:  knotes should be accessable.

Additional info:
Comment 1 Jeroen Beerstra 2005-02-26 18:51:32 EST
Confirmed on Fedora Core 3 x86_64

Also I would like to add, all notes added to knotes are lost upon restart. In
short knotes always starts with one initial blank note or when restored from a
previous kde session doesn start correctly (non clickable icon in kde systray).
Since remembering is what knotes is all about this pretty much makes it useless.  
Comment 2 Juliano F. Ravasi 2005-02-27 18:07:59 EST
knotes bug, don't know if already fixed on upstream.

My workaround:
1. Close knotes;
2. Check if you have a file ~/.kde/share/apps/knotesnotes.ics .
3. If so, open a terminal and write:
   cd ~/.kde/share/apps/knotes
   rm notes.ics
   ln -s ../knotesnotes.ics notes.ics

   (in other words, make a symlink named "notes.ics" on ~/.kde/share/apps/knotes
pointing to ~/.kde/share/apps/knotesnotes.ics)
4. Load knotes again;
5. Write something, close knotes and load it again to check if it worked.

Looks pretty clear what happened and how this bug was introduced... Let me know
if this worked for you.
Comment 3 David van Hoose 2005-03-23 12:57:45 EST
This has supposedly been fixed upstream according to bugs.kde.org. Shall 
RedHat give us the KDE 3.3.2 bug/security fix release? 
Comment 4 David Bestor 2006-01-10 06:29:43 EST
Doesn't this also affect RHEL 4 too?

This simple patch below should help:
see http://bugs.kde.org/show_bug.cgi?id=90744

--- kdepim-3.3.1.beforepatch99/knotes/resourcelocal.cpp 2004-10-03 03:44:33.0000
00000 -0400
+++ kdepim-3.3.1/knotes/resourcelocal.cpp       2006-01-08 01:05:59.000000000 -0
500
@@ -78,7 +78,7 @@
 
 bool ResourceLocal::save()
 {
-    QString file = KGlobal::dirs()->saveLocation( "data", "knotes" ) + "notes.i
cs";
+    QString file = KGlobal::dirs()->saveLocation( "data", "knotes/" ) + "notes.
ics";
 
     if ( !mCalendar.save( file, new KCal::ICalFormat() ) )
     {
Comment 5 Ngo Than 2006-06-22 18:04:07 EDT
this bug has been fixed in FC4/FC5 current release (kde-3.5.3). You should 
please update to the new version. Thanks

Note You need to log in before you can comment on or make changes to this bug.