Bug 1418822 - Puppet hosts in satellite web UI are incorrectly registered as FQDN
Summary: Puppet hosts in satellite web UI are incorrectly registered as FQDN
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.0
Hardware: All
OS: Linux
medium
high
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On: 1375706
Blocks: 1411935
TreeView+ depends on / blocked
 
Reported: 2017-02-02 19:46 UTC by pm-sat@redhat.com
Modified: 2020-02-14 18:31 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1375706
Environment:
Last Closed: 2018-09-04 17:58:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 17521 0 None None None 2017-11-03 13:53:59 UTC

Comment 2 Lukáš Hellebrandt 2017-10-09 14:00:16 UTC
FailedQA with Sat6.3 snap 19 and puppet-3.8.6-4 on client.

1) [client]# puppet agent -t --server <server_FQDN> --certname `hostname -s`
2) [server]# puppet cert sign <client_short_hostname>
3) [client]# systemctl start puppet
4) [client]# puppet agent -t --server <server_FQDN> --certname `hostname -s`
5) In WebUI, select any org, any context, go to Hosts->All Hosts. The host's name is client's FQDN.

Comment 3 pm-sat@redhat.com 2017-10-09 16:24:26 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 4 Justin Sherrill 2017-11-02 19:50:58 UTC
Removing upstream issue as it seems completely unrelated.

Comment 5 Justin Sherrill 2017-11-03 15:19:03 UTC
The issue attached to this bug was not correct, and the original bz that this was cloned from is still ASSIGNED, moving this one back to assigned.  

Lukas, I would like to point out that you failed_qa this not because the issue wasn't fixed, but because the reproducer steps were not fully adequate.  Foreman will always use whatever 'facter fqdn' returns for its host name.  I would recommend in the future a need_info in this case.  I believe the user's system was configured such that 'hostname -f' returned the short name.

the behavior you describe in comment #2 is exactly the same between 6.2 and 6.3 if 'hostname -f' returns the fqdn.

Comment 6 Bryan Kearney 2018-09-04 17:58:07 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.