Bug 1418848 - Subscription Manager sometimes submits an Installed Product to Candlepin with a null version
Summary: Subscription Manager sometimes submits an Installed Product to Candlepin with...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 21:29 UTC by Shayne Riley
Modified: 2021-01-15 07:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:31:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shayne Riley 2017-02-02 21:29:33 UTC
Description of problem:
In Candlepin, a consumer can list installed products. Each installed product will typically contain:
1. productId, e.g. 69
2. productName, e.g. Red Hat Enterprise Linux Server
3. version, e.g. 6.5
4. arch, e.g. x86_64

There are a few properties that should be met:
- It is expected that version will never be null.
- It is expected that arch will never be null.
- It is expected that arch will only contain one arch (that is, we expect "x86_64", and not something like "x86_64,ia64,x86")

However, looking at the Candlepin PROD DB, all of these properties have been broken by a few consumers. All have a null version, most will also have a null arch, and very few will have multiple arch's.

The reason why I'm listing this as a BZ with subscription-manager and not Candlepin is because I believe subscription-manager is not providing candlepin with the correct information in these instances.


Version-Release number of selected component (if applicable):
Hard to tell since the version is always null, but it happens to any RHEL Desktop/Server/Workstation, and I believe it can happen across version 6.x and 7.x.


How reproducible:
I've not reproduced it, but I can provide evidence that it continues to be stored in Candlepin


Steps to Reproduce:
1. Unknown

Actual results:
Installed products for a system can have a null version and a null arch. Or, a system can have a null version and a weird arch.


Expected results:
All Installed products will always specify a version and an arch.

Comment 3 Chris Snyder 2017-02-06 15:46:14 UTC
@devs: It looks likely that the installed product information is not being updated from a very old certificate. We should investigate if current subman product id logic will update the product cert to a new version in the case that there is a cert with a null version (or different arch data).

Comment 7 RHEL Program Management 2021-01-15 07:31:23 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.