Bug 141885 - aic7xxx device probe delayed with apm=power-off on smp kernel
aic7xxx device probe delayed with apm=power-off on smp kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-12-04 13:20 EST by Mark Wilkinson
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-07 02:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg from normal boot to single user mode (14.94 KB, text/plain)
2004-12-04 13:22 EST, Mark Wilkinson
no flags Details
dmesg from boot with apm=power-off option (11.69 KB, text/plain)
2004-12-04 13:23 EST, Mark Wilkinson
no flags Details

  None (edit)
Description Mark Wilkinson 2004-12-04 13:20:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Booting my system with the apm=power-off option causes the two SCSI
disks to not be recognised as the system starts up. As a result the
filesystems fail to mount and I get dumped into the repair filesystem
shell. Remove the option and the system starts up without problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. add apm=power-off option to kernel command line
2. boot system

Actual Results:  SCSI filesystems and RAID components are not found.

Expected Results:  System should boot normally. Additionally it would
be nice if it powered-off when shutdown, which is the aim of adding
the apm=power-off option. I can't see why changing an APM option would
alter the behaviour of the SCSI subsystem.

Additional info:

This is on an ABit VP6 motherboard with two PIII 866MHz processors.
The SCSI card is a 2940-UW with two SCSI drives connected to it.
I've tried a few different combinations of kernel command line options
(acpi=off, aic7xxx=verbose), but none help resolve the problem.
Comment 1 Mark Wilkinson 2004-12-04 13:22:42 EST
Created attachment 107899 [details]
dmesg from normal boot to single user mode
Comment 2 Mark Wilkinson 2004-12-04 13:23:39 EST
Created attachment 107900 [details]
dmesg from boot with apm=power-off option
Comment 3 Ville Steudle 2004-12-23 03:44:04 EST
Same issue here:

- AHA 29160
- SMP with two P3

Crashes with apm=power-off, worked fine with RH9 and kernels 2.4.x.

One issue to check is probably whether APM is available at initrd 
time: Is it in the kernel or in a module? If the latter, check 
whether it is in the initrd image.
Comment 4 Mark Wilkinson 2005-01-13 12:59:46 EST
Further bits of information:

I've upgraded the BIOS on the motherboard to the most recent one from
the vendor. This causes acpi to start working by default as the BIOS
now makes the cut off date. The machine still doesn't power down in
either acpi or apm=power-off modes, though. The problem described
above still exists when I use 'acpi=off apm=power-off'.

The machine starts up and shuts down correctly when using the
uniprocessor kernel. With acpi enabled the machine doesn't power off
on shutdown, but with acpi disabled and apm enabled it also powers off
properly. In fact, the machine will power off when booted with the SMP
kernel and the kernel parameters 'acpi=off apm=power-off'; it just
doesn't probe the SCSI bus properly.

During a normal boot there is a noticable (~15 second) pause while the
SCSI driver initialises and finds the attached devices. With the
apm=power-off command line flag present this delay isn't apparent. The
kernel sets about initialising other parts of the system. Perhaps some
lock is being disabled by the apm=power-off option, resulting in the
kernel not waiting for the SCSI driver to initialize.
Comment 5 Mark Wilkinson 2005-01-13 16:28:01 EST
Hmm; scratch the bit about it not powering down through ACPI. poweroff
from single user mode didn't seem to be doing it, but shut down from
run level 5 gets the system to power down.
Comment 6 Dave Atkinson 2005-02-16 20:03:16 EST
I think this is the cause of the behaviour I am seeing. I have a home-brewed
Gigabyte GA6-BXDU dual PIII w/onboard aic7896 SCSI.  I haven't been able to boot
from kernels 2.6.10-1.760_FC3smp or 2.6.10-1.766_FC3smp (not sure what happened
to 2.6.9-1.667 when I upgrade from FC2 but anyway...) but the uniprocessor
kernels are fine, as is 2.6.10-1.12_FC2smp (although a hand-rolled version,
1.12_FC2.rootsmp, also failed in exactly the same way?). 

The boot process proceeds as far as:

Loading aic7xxx.ko module

and then follows immediately with

Loading jdb.ko module
Loading ext3.ko module

and then falls over:

Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev/ failed: 2
Kernel panic - not syncing: Attempting to kill init!

I removed the "apm=power-off" option after reading the above and now at least
2.6.10-1.766_FC3smp boots, but does not shutdown automatically anymore.
Comment 7 Dave Jones 2005-07-15 15:10:45 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Richard Johnsson 2005-07-23 17:58:49 EDT
I just installed kernel-2.6.12-1.1372_FC3smp on an FC3 system that had been
happily running 2.6.11-1.14_FC3smp and encountered the same problem. The smp
kernel fails to find the root disk with a root=LABEL=/ parameter. Changing to
root=/dev/sda2 eliminates that message, but still fails to mount the root fs.

The non-smp kernel boots fine. I've compared the initrd contents and they are
the same, except, of course the actual modules are either the up or smp versions.

I did try acpi=off based on something I found on the web, but that didn't help.

My controller is a 3w_xxxx.
Comment 9 Dave Jones 2005-08-04 13:17:37 EDT
thats the bug in 163407 , which has nothing to do with this bug.
update mkinitd package first, then reinstall the kernel package.
Comment 10 Dave Jones 2005-12-07 02:57:38 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug with current FC3 updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

If you are not the reporter, but can reproduce this problem against
FC4, please open a new bug.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.