Bug 1418868 - Rebase to version smartmontools 6.5 for NVMe support
Summary: Rebase to version smartmontools 6.5 for NVMe support
Keywords:
Status: CLOSED DUPLICATE of bug 1369731
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: smartmontools
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-02-02 23:13 UTC by marc skinner
Modified: 2021-06-10 11:54 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-26 17:13:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description marc skinner 2017-02-02 23:13:47 UTC
Description of problem:

Current version in RHEL7.3.x is 
rpm -qa | grep smartmon
smartmontools-6.2-7.el7.x86_64

It doesn't support NVMe devices.

smartctl -x /dev/nvme01n1
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.10.0-514.6.1.el7.x86_64] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

/dev/nvme01n1: Unable to detect device type
Please specify device type with the -d option.


My system has 2 NVMe devices:

ls /dev/nvme*
/dev/nvme0  /dev/nvme0n1  /dev/nvme1  /dev/nvme1n1

Tooling should support NVMe devices to get statics regarding health of devices.

It looks like the smartmontools 6.5 has NVMe support.

Thanks.

Comment 2 Michal Hlavinka 2017-03-26 17:13:50 UTC

*** This bug has been marked as a duplicate of bug 1369731 ***


Note You need to log in before you can comment on or make changes to this bug.