Bug 1419254 - Could not start node service with OpenStack cloud provider enabled
Summary: Could not start node service with OpenStack cloud provider enabled
Keywords:
Status: CLOSED DUPLICATE of bug 1416703
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 10:28 UTC by Jianwei Hou
Modified: 2017-02-07 19:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 19:05:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jianwei Hou 2017-02-04 10:28:11 UTC
Description of problem:
Setup OCP on OpenStack with cloud provider enabled, node service could not be successfully started. Ansible installer failed at task 'openshift_node : Start and enable node'.

Version-Release number of selected component (if applicable):
atomic-openshift-node-3.5.0.16-1.git.0.a26133a.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup OCP on OpenStack with cloud provider enabled.

Actual results:
Ansible installer failed running task 'openshift_node : Start and enable node'.

Dug into log I found:

```
Feb  4 05:13:01 host-8-174-100 atomic-openshift-node: W0204 05:13:01.962769   22753 controller.go:71] Could not find an allocated subnet for node: qe-jhou-master-1, Waiting...
Feb  4 05:13:01 host-8-174-100 atomic-openshift-node: F0204 05:13:01.962790   22753 node.go:351] error: SDN node startup failed: Failed to get subnet for this host: qe-jhou-master-1, error: timed out waiting for the condition
```

Then in /etc/origin/node/node-config.yaml the nodeName was set as 'nodeName: qe-jhou-master-1', it needs to be overwritten by actual hostname 'host-8-174-100.host.centralci.eng.rdu2.redhat.com'. After changing nodeName in the node config, node service was started successfully. 

Expected results:
Installer should properly set node-config.yaml before starting node service.

Additional info:

Comment 1 Johnny Liu 2017-02-07 02:06:30 UTC
This bug is should be a dup with BZ#1416703, they have the same root cause.

Comment 2 Jason DeTiberus 2017-02-07 19:05:43 UTC

*** This bug has been marked as a duplicate of bug 1416703 ***


Note You need to log in before you can comment on or make changes to this bug.