Bug 1419286 - /usr/share/selinux/devel/include/services/container.if: Syntax error on line 42 ' [type=SQUOTE]
Summary: /usr/share/selinux/devel/include/services/container.if: Syntax error on line ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: container-selinux
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 20:54 UTC by Edgar Hoch
Modified: 2017-03-02 01:21 UTC (History)
6 users (show)

Fixed In Version: container-selinux-2.9-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 01:21:07 UTC
Type: Bug


Attachments (Terms of Use)
Patch for /usr/share/selinux/devel/include/services/container.if (358 bytes, patch)
2017-02-04 20:56 UTC, Edgar Hoch
no flags Details | Diff

Description Edgar Hoch 2017-02-04 20:54:10 UTC
Description of problem:

Installation of package selinux-policy-devel prints the following error:

/usr/share/selinux/devel/include/services/container.if: Syntax error on line 42 ' [type=SQUOTE]
/usr/share/selinux/devel/include/services/container.if: Syntax error on line 46 ' [type=SQUOTE]

This is because it contains a postinstall script:

# rpm -q --scripts selinux-policy-devel
postinstall scriptlet (using /bin/sh):
selinuxenabled && /usr/bin/sepolgen-ifgen 2>/dev/null 
exit 0


Version-Release number of selected component (if applicable):
container-selinux-2.5-1.fc25.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install packages if they are not already installed:
   dnf install container-selinux selinux-policy-devel
2. To see the error independent of package installation, run
   /usr/bin/sepolgen-ifgen


Actual results:
Error messages:
/usr/share/selinux/devel/include/services/container.if: Syntax error on line 42 ' [type=SQUOTE]
/usr/share/selinux/devel/include/services/container.if: Syntax error on line 46 ' [type=SQUOTE]


Expected results:
No error messages

Comment 1 Edgar Hoch 2017-02-04 20:56:20 UTC
Created attachment 1247734 [details]
Patch for /usr/share/selinux/devel/include/services/container.if

Solution:
File /usr/share/selinux/devel/include/services/container.if line 42
should end with a ";" .
See patch.

Comment 2 Daniel Walsh 2017-02-06 23:12:17 UTC
fixed in container-selinux-2.7

Comment 3 Fedora Update System 2017-02-27 17:18:39 UTC
container-selinux-2.9-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-018d2c13f7

Comment 4 Fedora Update System 2017-03-01 02:52:56 UTC
container-selinux-2.9-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-018d2c13f7

Comment 5 Fedora Update System 2017-03-02 01:21:07 UTC
container-selinux-2.9-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.