Bug 1419484 - virt-manager shows some running VMs as paused
Summary: virt-manager shows some running VMs as paused
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 10:18 UTC by Gavin Brebner
Modified: 2018-03-27 16:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-10 22:32:26 UTC


Attachments (Terms of Use)
Screenshot showing running VM marked as "Paused" (27.34 KB, image/png)
2017-02-06 10:18 UTC, Gavin Brebner
no flags Details

Description Gavin Brebner 2017-02-06 10:18:48 UTC
Created attachment 1247994 [details]
Screenshot showing running VM marked as "Paused"

Description of problem:


Version-Release number of selected component (if applicable):

virt-manager 1.3.2

Running on 

gavin@gbws ~ $ cat /etc/lsb-release 
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=18
DISTRIB_CODENAME=sarah
DISTRIB_DESCRIPTION="Linux Mint 18 Sarah"
gavin@gbws ~ $ cat /etc/upstream-release/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

Seen with vagrant 1.8.6 and 1.9.1


How reproducible:

Seen frequently - when creating 4 VMs, generally one or two are in this state.


Steps to Reproduce:
1. Create vagrant file that specifies multiple VMs and uses the libvirt provider
2. vagrant up
3. start virt-manager

Actual results:

virt-manager shows the created VMs, but one or more will be shown as "Paused",
even although the CPU usage / Network I/O  charts show activity. virsh list also shows the VMs as running and the VMs are accessible. As such this is a purely cosmetic issue.

Expected results:

All VMs correctly shown as running.

Additional info:

This behaviour seems to have been introduced by a recent change. I hit this shortly after an apt update && apt upgrade

Comment 1 Cole Robinson 2017-03-29 18:08:28 UTC
There's been several new releases since virt-manager 1.3.2. Please try the latest code and see if it reproduces, and if so, attach the --debug output

git clone git://github.com/virt-manager/virt-manager
cd virt-manager
./virt-manager --debug

Comment 2 Cole Robinson 2017-05-10 22:32:26 UTC
Since there hasn't been a follow up, closing this as DEFERRED. Please reopen if the latest release still reproduces this issue

Comment 3 Dylan Stephano-Shachter 2018-03-27 16:34:13 UTC
I have also been seeing this. It seems to have started in the last few days but I haven't updated at all. I'm currently running version 1.5.0 (slightly modified).


Note You need to log in before you can comment on or make changes to this bug.