Bug 141953 - init: open(/dev/pts/0): No such file or directory
Summary: init: open(/dev/pts/0): No such file or directory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhgb   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 11:25 UTC by Bernd Bartmann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: Fedora 7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 20:57:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/inittab (1.63 KB, text/plain)
2004-12-06 20:24 UTC, Bernd Bartmann
no flags Details
patch to fix broken rhgb exit() behavior (777 bytes, patch)
2005-01-28 21:52 UTC, Bill Nottingham
no flags Details | Diff
Changes console right before exit (40 bytes, patch)
2007-01-09 16:29 UTC, Baris Cicek
no flags Details | Diff

Description Bernd Bartmann 2004-12-06 11:25:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
As I don't know which component is responsible here I file it against
distribution.

After logging out of the console I get this message in /var/log/messages:

init: open(/dev/pts/0): No such file or directory

This does not happen if I login via ssh.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login / Logout
2.
3.
    

Additional info:

Comment 1 Bill Nottingham 2004-12-06 20:11:59 UTC
Please attach your inittab.

Comment 2 Bernd Bartmann 2004-12-06 20:24:06 UTC
Created attachment 107986 [details]
/etc/inittab

The only thing I've changed against the stock FC3 inittab was to disable
CTRL-ALT-DEL.

Comment 3 Bill Nottingham 2005-01-28 06:39:26 UTC
I'm assuming you're using rhgb.

Does /proc/*/fd for mingetty look odd at all?
What does /proc/*/environ for mingetty  have for CONSOLE?

Comment 4 Bernd Bartmann 2005-01-28 16:50:10 UTC
mingetty for tty4 is process 5064
ls -l /proc/5064/fd gives:
lrwx------  1 root root 64 28. Jan 17:32 0 -> /dev/tty4
lrwx------  1 root root 64 28. Jan 17:32 1 -> /dev/tty4
lrwx------  1 root root 64 28. Jan 17:32 2 -> /dev/tty4
lr-x------  1 root root 64 28. Jan 17:32 3 -> /init

CONSOLE=/dev/pts/0 in /proc/5064/environ

I get similar results for all other ttys.

Comment 5 Bill Nottingham 2005-01-28 21:52:41 UTC
Created attachment 110371 [details]
patch to fix broken rhgb exit() behavior

Try this. If you need a test build of the package, shout.

Comment 6 Bernd Bartmann 2005-01-29 11:31:01 UTC
Thanks Bill, your patch makes the error message go away.

Comment 7 Bill Nottingham 2005-01-31 21:27:33 UTC
Update for rhgb pushed.

Comment 8 Orion Poplawski 2006-12-15 18:03:31 UTC
I'm seeing this again on FC6 with rhgb-0.16.4-3.fc6, though only on one machine
out of four installed so far.

Comment 9 Baris Cicek 2007-01-09 16:29:15 UTC
Created attachment 145174 [details]
Changes console right before exit

There seems to be a regression so that last system(FIX_INIT_COMMAND) before
quiting rhgb is lost. This patch adds that line. I did not get any init: open
(..) errors after applying this patch.

Comment 10 Ray Strode [halfline] 2007-08-14 20:57:39 UTC
This should be fixed in F7.


Note You need to log in before you can comment on or make changes to this bug.