Bug 141956 - pilot-link chokes on transfers with treo600
pilot-link chokes on transfers with treo600
Status: CLOSED DUPLICATE of bug 140125
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 06:51 EST by Bowe Strickland
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel messages during pilot-xfer -b . w/ visor moduleparm debug=1 (30.84 KB, text/plain)
2004-12-07 00:02 EST, Bowe Strickland
no flags Details

  None (edit)
Description Bowe Strickland 2004-12-06 06:51:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
pilot-xfer hangs after backing up a file ("pdc") or two,
with treo presenting a "bad transfer" dialog but
pilot-xfer still trying to communicate (must be killed by signal):

-------------------------------------------------------
[root@rose manual]# pilot-xfer -b .
   No $PILOTPORT specified and no -p <port> given.
   Defaulting to '/dev/pilot'


   Listening to port: /dev/pilot

   Please press the HotSync button now... Connected

Backing up ./Batcam_Bcam_appl_a68k.prc
Backing up ./Blazer Cache.pdb
(CTRL-C)
--------------------------------------------------------

syncs like a charm on FC2, so don't think it's hardware related.
also, FC3 was able to install initial username and id.

treo600 OS details:
Firmware: 0305
Software: Treo600-1.12-CNG
Hardware: B

Version-Release number of selected component (if applicable):
pilot-link-0.11.8-8

How reproducible:
Always

Steps to Reproduce:
1. mknod /dev/pilot c 188 1 (udev has some other issues, but that's
for another day...)
2. press hotsync on treo to start USB
3. pilot-sync -b .
    

Actual Results:  first file transfers, second file hangs, almost
always at the
same spot.  similar behavior when attemtping to sync
with gpilotd.

Expected Results:  all files should have been backed up from treo.

Additional info:
Comment 1 Ngo Than 2004-12-06 08:53:12 EST
have you seen any errors or warnings by starting pilot-sync -b .?
it sounds a bug in USB driver.

Could you please attach the output of dmesg after the process hangs?
thanks
Comment 2 Bowe Strickland 2004-12-06 15:28:57 EST
Fun... I'm up for a recompile of visor, if needed ;)...


terminal 1:
--------------------------------------------------------------------
[root@dhcp63-233 ~]# mknod /dev/pilot c 188 1
[root@dhcp63-233 treo]# pilot-xfer -b .
   No $PILOTPORT specified and no -p <port> given.
   Defaulting to '/dev/pilot'

   Port not connected, sleeping for 2 seconds, 3 retries..
   Listening to port: /dev/pilot

   Please press the HotSync button now... Connected

Backing up ./PixerRecentRecipientListDB.pdb
Backing up ./Batcam_Bcam_appl_a68k.prc
Backing up ./Blazer Cache.pdb
(hang.....)
--------------------------------------------------------------------

terminal 2
---------------------------------------------------------------------
[root@dhcp63-233 ~]# killall klogd
[root@dhcp63-233 ~]# cat /proc/kmsg
(push hotsync, twadeedee from treo)
<6>drivers/usb/serial/usb-serial.c: USB Serial support registered for
Generic
<6>usbcore: registered new driver usbserial_generic
<6>usbcore: registered new driver usbserial
<6>drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
<6>usb 3-2: new full speed USB device using address 2
<6>drivers/usb/serial/usb-serial.c: USB Serial support registered for
Handspring Visor / Palm OS
<6>drivers/usb/serial/usb-serial.c: USB Serial support registered for
Sony Clie 3.5
<6>drivers/usb/serial/usb-serial.c: USB Serial support registered for
Sony Clie 5.0
<6>visor 3-2:1.0: Handspring Visor / Palm OS converter detected
<6>usb 3-2: Handspring Visor / Palm OS converter now attached to ttyUSB0
<6>usb 3-2: Handspring Visor / Palm OS converter now attached to ttyUSB1
<6>usbcore: registered new driver visor
<6>drivers/usb/serial/visor.c: USB HandSpring Visor / Palm OS driver v2.1
(tweedodooo from treo as hotsync app on treo drops connection)
<6>usb 3-2: USB disconnect, address 2
<6>visor 3-2:1.0: device disconnected
Comment 3 Bowe Strickland 2004-12-07 00:02:31 EST
Created attachment 108019 [details]
kernel messages during pilot-xfer -b . w/ visor moduleparm debug=1

found visor's debug module param... here's kernel messeges
during pilot-xfer w/ debug=1.
Comment 4 Ngo Than 2004-12-07 10:49:41 EST
it looks like the same bug #140125. 

*** This bug has been marked as a duplicate of 140125 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:07:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.