Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419578 - gimp crashes when selecting fonts in text tool dialog
Summary: gimp crashes when selecting fonts in text tool dialog
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 14:55 UTC by Rabin
Modified: 2017-05-29 06:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-29 06:34:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Rabin 2017-02-06 14:55:29 UTC
Description of problem:

This is duplicate of bug #119077 with the same title.


Version-Release number of selected component (if applicable): 

gimp-2:2.8.18-1.fc25.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Having one of the fonts on "Additional info" list
2. Open the font selection or scroll through it.

Actual results: 

  gimp will crash


Expected results:
 
  Allow font selection


Additional info:

The problem goes after removing the following fonts, 
which IIRC are all from Google Fonts

+..... /usr/local/share/fonts/Amatica_SC
+..... /usr/local/share/fonts/Amatica_SC/AmaticaSC-Bold.ttf
+..... /usr/local/share/fonts/Amatica_SC/AmaticaSC-Regular.ttf
+..... /usr/local/share/fonts/Amatica_SC/OFL.txt
+..... /usr/local/share/fonts/Arimo
+..... /usr/local/share/fonts/Arimo/Arimo-BoldItalic.ttf
+..... /usr/local/share/fonts/Arimo/Arimo-Bold.ttf
+..... /usr/local/share/fonts/Arimo/Arimo-Italic.ttf
+..... /usr/local/share/fonts/Arimo/Arimo-Regular.ttf
+..... /usr/local/share/fonts/Arimo/LICENSE.txt
+..... /usr/local/share/fonts/Assistant
+..... /usr/local/share/fonts/Assistant/Assistant-Bold.ttf
+..... /usr/local/share/fonts/Assistant/Assistant-ExtraBold.ttf
+..... /usr/local/share/fonts/Assistant/Assistant-ExtraLight.ttf
+..... /usr/local/share/fonts/Assistant/Assistant-Light.ttf
+..... /usr/local/share/fonts/Assistant/Assistant-Regular.ttf
+..... /usr/local/share/fonts/Assistant/Assistant-SemiBold.ttf
+..... /usr/local/share/fonts/Assistant/OFL.txt
+..... /usr/local/share/fonts/Heebo
+..... /usr/local/share/fonts/Heebo/Heebo-Black.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-Bold.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-ExtraBold.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-Light.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-Medium.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-Regular.ttf
+..... /usr/local/share/fonts/Heebo/Heebo-Thin.ttf
+..... /usr/local/share/fonts/Heebo/OFL.txt
+..... /usr/local/share/fonts/Miriam_Libre
+..... /usr/local/share/fonts/Miriam_Libre/MiriamLibre-Bold.ttf
+..... /usr/local/share/fonts/Miriam_Libre/MiriamLibre-Regular.ttf
+..... /usr/local/share/fonts/Miriam_Libre/OFL.txt
+..... /usr/local/share/fonts/Rubik
+..... /usr/local/share/fonts/Rubik/OFL.txt
+..... /usr/local/share/fonts/Rubik/Rubik-BlackItalic.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Black.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-BoldItalic.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Bold.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Italic.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-LightItalic.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Light.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-MediumItalic.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Medium.ttf
+..... /usr/local/share/fonts/Rubik/Rubik-Regular.ttf
+..... /usr/local/share/fonts/Secular_One
+..... /usr/local/share/fonts/Secular_One/OFL.txt
+..... /usr/local/share/fonts/Secular_One/SecularOne-Regular.ttf
+..... /usr/local/share/fonts/Suez_One
+..... /usr/local/share/fonts/Suez_One/OFL.txt
+..... /usr/local/share/fonts/Suez_One/SuezOne-Regular.ttf
+..... /usr/local/share/fonts/Varela_Round
+..... /usr/local/share/fonts/Varela_Round/OFL.txt
+..... /usr/local/share/fonts/Varela_Round/VarelaRound-Regular.ttf

Comment 1 Josef Ridky 2017-05-24 13:17:34 UTC
There is new version of gimp package (gimp-2.8.22-2).

Please, try this version and let us know, if the issue persist.

When I have tested this issue with Assistant font and I wasn't able to reproduce it.

Comment 2 Rabin 2017-05-26 14:46:39 UTC
Happen again, but then I found that permmision on the files is RO for root only

/usr/local/share/fonts/Google_Fonts  ll
total 0
0 drwxr-xr-x. 12 root root 169 May 26 17:36 .
0 drwxr-xr-x. 10 root root 134 May 26 17:36 ..
0 drwx------.  2 root root  76 May 26 17:36 Amatica_SC
0 drwx------.  2 root root 124 May 26 17:36 Arimo
0 drwx------.  2 root root 196 May 26 17:36 Assistant
0 drwx------.  2 root root 187 May 26 17:36 Heebo
0 drwx------.  2 root root  80 May 26 17:36 Miriam_Libre
0 drwx------.  2 root root 278 May 26 17:36 Rubik
0 drwx------.  2 root root  51 May 26 17:36 Secular_One
0 drwx------.  2 root root  48 May 26 17:36 Suez_One
0 drwx------.  2 root root  47 May 26 17:36 Varela
0 drwx------.  2 root root  52 May 26 17:36 Varela_Round

After fixing the permission problem, gimp didn't crash again.

Comment 3 Josef Ridky 2017-05-29 06:34:41 UTC
Based on comment #2:

Issue was caused by wrong file permission. Due this I am closing this as NOTABUG.

Comment 4 Rabin 2017-05-29 06:48:00 UTC
@Josef please note, that I can't confirm that was the case, as this bug report was from a different machine which I don't have any-more.

The listing above is from my current machine.


Note You need to log in before you can comment on or make changes to this bug.