Bug 141981 - USB 2.0 external hard disks disconnect during massive writes.
USB 2.0 external hard disks disconnect during massive writes.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 11:09 EST by Thomas Bub
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 02:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Bub 2004-12-06 11:09:12 EST
Description of problem:
I'm having trouble with a external USB 2.0 hard drives.
They got recognized fine, I can mount them but as soon as I try to 
write massive ammount of data to them they disconnect by tehmselves.
I've crossed check with two different USB 2.0 drives of different 
vendors and two indentical HP xw8000 workstations with same 2.4.21-
15.ELsmp kernel.
It is always the same

How reproducible:

Steps to Reproduce:
1.Plug-IN external USB 2.0 hard drive
2.Mount the drive
3.Start copying massive ammount of dat to it.
4.The copy operation stalls/aborts
  
Actual results:
Here is the relevant part of the /var/log/messages file. The trouble 
starts with the "kernel: usb_control/bulk_msg: timeout" message

Dec  3 14:00:02 xw8000 kernel: SCSI device sdp: 160086528 512-byte 
hdwr sectors (81964 MB)
Dec  3 14:00:02 xw8000 kernel:  sdp: sdp1
Dec  3 14:00:02 xw8000 kernel: USB Mass Storage support registered.
Dec  3 14:00:05 xw8000 devlabel: devlabel service started/restarted
Dec  3 14:02:32 xw8000 kernel: usb_control/bulk_msg: timeout
Dec  3 14:02:52 xw8000 last message repeated 2 times
Dec  3 14:02:52 xw8000 kernel: usb.c: USB disconnect on device 
00:1d.7-6 address 2
Dec  3 14:02:57 xw8000 kernel: Device 08:f1 not ready.
Dec  3 14:02:57 xw8000 kernel:  I/O error: dev 08:f1, sector 99073
Dec  3 14:02:57 xw8000 kernel: Device 08:f1 not ready.
Dec  3 14:02:57 xw8000 kernel:  I/O error: dev 08:f1, sector 99328
Dec  3 14:02:57 xw8000 kernel: Device 08:f1 not ready.
Dec  3 14:02:57 xw8000 kernel:  I/O error: dev 08:f1, sector 99583
Dec  3 14:02:57 xw8000 kernel: Device 08:f1 not ready.
...
..
..


Expected results:
No disconnect of external hard drive

Additional info:

Here is the list of the USB devices.
 
:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 6
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.04
S:  Manufacturer=Linux 2.4.21-15.ELsmp4G ehci-hcd
S:  Product=Intel Corp. 82801DB USB2
S:  SerialNumber=00:1d.7
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=256ms
T:  Bus=04 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=05e3 ProdID=0702 Rev= 0.02
S:  Manufacturer=Genesyslogic
S:  Product=USB Mass Storage Device
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  4mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-
storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=18c0
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=18a0
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=1880
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
Comment 1 Pete Zaitcev 2005-12-22 15:20:06 EST
This is a tough one, unfortunately, primarily because it needs the specific
hardware to get reproduced.

RHEL 4 has an EHCI which may be more gentle here.

Note You need to log in before you can comment on or make changes to this bug.