Bug 1420018 - timelines doesn't display all events in its view
Summary: timelines doesn't display all events in its view
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Dave Johnson
URL:
Whiteboard: ui:timeline
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 15:42 UTC by Ievgen Zapolskyi
Modified: 2017-02-07 17:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 17:09:44 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:
izapolsk: automate_bug+


Attachments (Terms of Use)
screen shot (255.56 KB, image/png)
2017-02-07 15:44 UTC, Ievgen Zapolskyi
no flags Details

Description Ievgen Zapolskyi 2017-02-07 15:42:14 UTC
Description of problem:
Where there are a lot of events happened in short period, only part of events is displayed. The rest of events are put out of view and invisible as a result.

Version-Release number of selected component (if applicable):
5.6.4.0

How reproducible:
100%

Steps to Reproduce:
1. Do something that would cause generation of 25-30+ power on/off events.(I just use provider vsphere55 provider which is also used by other teammates and autotests)
2. Open Timelines for Provider/Host/Cluster
3. Choose Power Activity
4. Compare number of power events for this Provider in Timelines and event_streams table (Actually, I see that events for my vm aren't displayed at all in timelines view because of other events)

Actual results:
only part of events present in event_streams table are present. rest of events isn't displayed or displayed out of timelines view.

Expected results:
all events of appropriate categories should be displayed correctly

Additional info: I've attached screenshot but I'm not sure that it can display the issue.

Comment 2 Ievgen Zapolskyi 2017-02-07 15:44:34 UTC
Created attachment 1248439 [details]
screen shot


Note You need to log in before you can comment on or make changes to this bug.