Bug 142010 - Omission a of Kernel sources is a BAD thing.
Summary: Omission a of Kernel sources is a BAD thing.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 18:40 UTC by Frank Earl
Modified: 2015-01-04 22:13 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-06 18:41:56 UTC


Attachments (Terms of Use)

Description Frank Earl 2004-12-06 18:40:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Whether or not you consider it to be "redundant" or not, it is
excessively problematic to omit the kernel sources as there is still
quite a few things end-users have to recompile the kernel to properly
support their devices on their machines.  In some situations, it could
be their ONLY ethernet adapter (Atheros and no wireline network...) or
they're on dialup and some friend handed them a CD set or DVD set. 
Mandrake got taken to task for this with the 9.2 release and it's
rather stupid to do this sort of thing unless you can guarantee
99-100% out of the box hardware coverage.  If this is a space
decision, pick something else to remove from Core 4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just install FC3 with something that needs kernel sources to build.
2.
3.
    

Expected Results:  The kernel sources should have been available as
something other than an SRPM because of the actual needs for all users.

Additional info:

Comment 1 Dave Jones 2004-12-06 18:41:56 UTC
please read the release notes.



Note You need to log in before you can comment on or make changes to this bug.