Bug 1420259 - CPU hot unplug should only be offered for OS that support it
Summary: CPU hot unplug should only be offered for OS that support it
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.4
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ovirt-4.2.0
: ---
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 10:04 UTC by Evgheni Dereveanchin
Modified: 2017-11-22 12:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-14 11:08:05 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)

Description Evgheni Dereveanchin 2017-02-08 10:04:51 UTC
Description of problem:
Currently the admin portal will allow CPU hotplug to any VM while when trying to execute the change it will fail with error if the OS is not supported:

Failed to hot set number of CPUS to VM vm2. Underlying error message: Hot un-plugging a CPU is not supported for the guest OS Other OS and architecture x86_64

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.0.4-1.el7

How reproducible:
always

Steps to Reproduce:
1. create VM with 2 CPUs and set operating system to "Other OS" in the UI
2. start VM
3. edit VM and set CPU to 1, click OK

Actual results:
 "Changes that can be applied immediately" screen is displayed
 when OK is pressed, unplug fails immediately due to OS type set in UI:
 "Failed to hot set number of CPUS to VM vm2. Underlying error message: Hot un-plugging a CPU is not supported for the guest OS Other OS and architecture x86_64"

Expected results:
 "Changes that require Virtual Machine restart" screen is displayed
 hot unplug not attempted

Additional info:

Comment 1 Michal Skrivanek 2017-02-09 05:42:35 UTC
There's no feasible infra to be able to do that within edit vm dialog. It would require changing the way hotplug/unplug is exposed to users
Not worth the effort

I'll keep the bug around for a while if someone wants to work on that, but it's unlikely...

Comment 2 Michal Skrivanek 2017-08-14 11:08:05 UTC
no one volunteered, closing the bug then


Note You need to log in before you can comment on or make changes to this bug.