Bug 1420368 - [RFE] Install rhosp-release on the undercloud (Need a method to identify what version OSP is running on the Undercloud)
Summary: [RFE] Install rhosp-release on the undercloud (Need a method to identify what...
Keywords:
Status: CLOSED DUPLICATE of bug 1493564
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks: 1305654
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:26 UTC by Randy Perryman
Modified: 2017-10-23 18:50 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-23 18:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Randy Perryman 2017-02-08 14:26:10 UTC
Description of problem:
In doing Updates and Upgrades, I have a need to identify what version is running on all components and where they land in relation to OSP version.

Version-Release number of selected component (if applicable):
 OSP 8,9,10,11...

How reproducible:
Always

Comment 2 Mike Burns 2017-02-09 12:31:05 UTC
We have a solution for the overcloud starting in OSP 10.  For older releases, we would need to depend on the version of packages installed, for example openstack-nova.  

This bug can be for having a way to identify the version on the undercloud.

Comment 3 Red Hat Bugzilla Rules Engine 2017-02-09 12:31:12 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Mike Burns 2017-05-26 14:05:13 UTC
Moving this to a different component.  We have rhosp-release on the overcloud starting in OSP 10, so altering title to be undercloud only.  

We likely need a solution to install rhosp-release on the undercloud.  A workaround for 10+ is to yum install rhosp-release.

Comment 7 Jaromir Coufal 2017-10-23 18:48:38 UTC

*** This bug has been marked as a duplicate of bug 1493564 ***

Comment 8 Jaromir Coufal 2017-10-23 18:50:10 UTC
There was another duplicite bug, closing this one in benefit of the other one since it had more info in discussions.


Note You need to log in before you can comment on or make changes to this bug.